summaryrefslogtreecommitdiff
path: root/meta/packages/uuid
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2008-10-29 16:32:03 +0000
committerJoshua Lock <josh@linux.intel.com>2008-10-29 16:34:47 +0000
commitdb5f7b918b7384bfd7a83b5fd17c181cd1d9487b (patch)
tree5f15d91aa9318197c9082e289d8a52bf0f313468 /meta/packages/uuid
parent410141a9079202061c10a17e7d2a2c2f4d4e561d (diff)
downloadopenembedded-core-db5f7b918b7384bfd7a83b5fd17c181cd1d9487b.tar.gz
openembedded-core-db5f7b918b7384bfd7a83b5fd17c181cd1d9487b.tar.bz2
openembedded-core-db5f7b918b7384bfd7a83b5fd17c181cd1d9487b.tar.xz
openembedded-core-db5f7b918b7384bfd7a83b5fd17c181cd1d9487b.zip
packages: check, uuid and xerces.
Add recipes for: updated check, 0.9.5 uuid 1.6.2 xerces-c 2.8.0
Diffstat (limited to 'meta/packages/uuid')
-rw-r--r--meta/packages/uuid/files/fixes.patch42
-rw-r--r--meta/packages/uuid/uuid_1.6.2.bb15
2 files changed, 57 insertions, 0 deletions
diff --git a/meta/packages/uuid/files/fixes.patch b/meta/packages/uuid/files/fixes.patch
new file mode 100644
index 000000000..8a792c723
--- /dev/null
+++ b/meta/packages/uuid/files/fixes.patch
@@ -0,0 +1,42 @@
+Index: uuid-1.6.2/Makefile.in
+===================================================================
+--- uuid-1.6.2.orig/Makefile.in 2008-10-29 04:37:32.000000000 +0000
++++ uuid-1.6.2/Makefile.in 2008-10-29 04:40:18.000000000 +0000
+@@ -55,7 +55,6 @@
+ CP = cp
+ RMDIR = rmdir
+ SHTOOL = $(S)/shtool
+-LIBTOOL = $(C)/libtool
+ TRUE = true
+ POD2MAN = pod2man
+ PERL = @PERL@
+Index: uuid-1.6.2/configure.ac
+===================================================================
+--- uuid-1.6.2.orig/configure.ac 2008-10-29 04:31:31.000000000 +0000
++++ uuid-1.6.2/configure.ac 2008-10-29 04:33:07.000000000 +0000
+@@ -40,11 +40,8 @@
+
+ AC_PROG_MAKE_SET
+ AC_PROG_CC
+-AC_CHECK_DEBUGGING
+-AC_CHECK_DMALLOC
+
+ with_tags=""
+-sinclude(libtool.m4)
+ AC_PROG_LIBTOOL
+
+ sinclude(uuid.ac)
+Index: uuid-1.6.2/uuid.ac
+===================================================================
+--- uuid-1.6.2.orig/uuid.ac 2008-10-29 04:31:39.000000000 +0000
++++ uuid-1.6.2/uuid.ac 2008-10-29 04:31:53.000000000 +0000
+@@ -39,9 +39,6 @@
+ fi
+ AC_CHECK_LIB(socket, accept)
+
+- dnl # check for portable va_copy()
+- AC_CHECK_VA_COPY()
+-
+ dnl # check for system headers
+ AC_CHECK_HEADERS(sys/types.h sys/param.h sys/time.h sys/socket.h sys/sockio.h sys/ioctl.h sys/select.h)
+ AC_CHECK_HEADERS(netdb.h ifaddrs.h net/if.h net/if_dl.h net/if_arp.h netinet/in.h arpa/inet.h,,,
diff --git a/meta/packages/uuid/uuid_1.6.2.bb b/meta/packages/uuid/uuid_1.6.2.bb
new file mode 100644
index 000000000..eb76349d8
--- /dev/null
+++ b/meta/packages/uuid/uuid_1.6.2.bb
@@ -0,0 +1,15 @@
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \
+ file://fixes.patch;patch=1"
+PR = "r0"
+
+inherit autotools
+
+do_configure_prepend () {
+ rm libtool.m4
+}
+
+export LIBTOOL = "${S}/${TARGET_PREFIX}libtool"
+
+do_stage () {
+ autotools_stage_all
+} \ No newline at end of file