summaryrefslogtreecommitdiff
path: root/meta/packages/xorg-lib/libx11_1.1.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-28 15:35:03 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-28 15:35:03 +0000
commit8e3e46639f903a527ce52310bc91b46c65f0e580 (patch)
treeb918a7814b8d5e8f584bdafcafccd58c131d5354 /meta/packages/xorg-lib/libx11_1.1.4.bb
parentc81efe4382dca04e93dbddf4869cd83c532332d6 (diff)
downloadopenembedded-core-8e3e46639f903a527ce52310bc91b46c65f0e580.tar.gz
openembedded-core-8e3e46639f903a527ce52310bc91b46c65f0e580.tar.bz2
openembedded-core-8e3e46639f903a527ce52310bc91b46c65f0e580.tar.xz
openembedded-core-8e3e46639f903a527ce52310bc91b46c65f0e580.zip
libx11: upgraded to 1.1.4
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4143 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-lib/libx11_1.1.4.bb')
-rw-r--r--meta/packages/xorg-lib/libx11_1.1.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/xorg-lib/libx11_1.1.4.bb b/meta/packages/xorg-lib/libx11_1.1.4.bb
new file mode 100644
index 000000000..88771558f
--- /dev/null
+++ b/meta/packages/xorg-lib/libx11_1.1.4.bb
@@ -0,0 +1,29 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "Base X libs."
+DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
+ libxdmcp xf86bigfontproto kbproto inputproto"
+PROVIDES = "virtual/libx11"
+PE = "1"
+PR = "r3"
+
+XORG_PN = "libX11"
+
+SRC_URI += "file://x11_disable_makekeys.patch;patch=1 \
+ file://include_fix.patch;patch=1"
+
+EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
+ cd src/util; touch makekeys-makekeys.o ; ${BUILD_CC} ${BUILD_CFLAGS} makekeys.c -o makekeys
+ # mv to stop it getting rebuilt
+ mv makekeys.c makekeys.c.orig
+ cd ../../
+ ) || exit 1
+ oe_runmake
+}
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${libdir}/X11/Xcms.txt"
+FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"