summaryrefslogtreecommitdiff
path: root/meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-05-22 09:13:24 +0000
committerRichard Purdie <richard@openedhand.com>2008-05-22 09:13:24 +0000
commit691f2eb5764d72801cecd8ab999782777d556b61 (patch)
treec4579cf668456468919d3f99457821bdc0ad0f9e /meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
parent0ce2f383d6e52a907fae86b95df889a8bf9daa8c (diff)
downloadopenembedded-core-691f2eb5764d72801cecd8ab999782777d556b61.tar.gz
openembedded-core-691f2eb5764d72801cecd8ab999782777d556b61.tar.bz2
openembedded-core-691f2eb5764d72801cecd8ab999782777d556b61.tar.xz
openembedded-core-691f2eb5764d72801cecd8ab999782777d556b61.zip
Add xserver-kdrive-glamo from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4538 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb')
-rw-r--r--meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb b/meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
new file mode 100644
index 000000000..6fce2bd5c
--- /dev/null
+++ b/meta/packages/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "X server for glamo chip in GTA02"
+SECTION = "x11/base"
+LICENSE = "MIT"
+DEPENDS = "compositeproto damageproto fixesproto recordproto resourceproto \
+ scrnsaverproto xineramaproto videoproto xextproto xproto \
+ libxau libxext libxdmcp libxfont libxrandr tslib virtual/libx11 \
+ xtrans libxkbfile libxcalibrate"
+DEPENDS += "libxkbfile libxcalibrate"
+RDEPENDS_${PN} = "xserver-kdrive"
+PROVIDES = "virtual/xserver"
+PE = "1"
+PR = "r6"
+PV = "1.3.0.0+git${SRCREV}"
+
+SRC_URI = "git://people.freedesktop.org/~dodji/xglamo;protocol=git \
+ file://kmode.patch;patch=1 \
+ file://disable-apm.patch;patch=1 \
+ file://no-serial-probing.patch;patch=1 \
+ file://fbdev-not-fix.patch;patch=1 \
+ file://optional-xkb.patch;patch=1 \
+ file://enable-tslib.patch;patch=1 \
+ file://kmode-palm.patch;patch=1 \
+ file://enable-epson.patch;patch=1 \
+ file://enable-builtin-fonts.patch;patch=1 \
+ file://kdrive-evdev.patch;patch=1 \
+ file://kdrive-use-evdev.patch;patch=1 \
+ file://disable-xf86-dga-xorgcfg.patch;patch=1 \
+ file://fix_default_mode.patch;patch=1 \
+ file://enable-xcalibrate.patch;patch=1 \
+ file://hide-cursor-and-ppm-root.patch;patch=1 \
+ file://xcalibrate_coords.patch;patch=1 \
+ file://w100.patch;patch=1 \
+ file://w100-autofoo.patch;patch=1 \
+ file://w100-fix-offscreen-bmp.patch;patch=1 \
+ file://kdrive-1.3-18bpp.patch;patch=1 \
+ file://gumstix-kmode.patch;patch=1 \
+ file://fix-picturestr-include-order.patch;patch=1 \
+"
+
+FILESPATH = "${FILE_DIRNAME}/xserver-kdrive-glamo:${FILE_DIRNAME}/xserver-kdrive-1.3.0.0:${FILE_DIRNAME}/xserver-kdrive:${FILE_DIRNAME}/files"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-composite --enable-kdrive \
+ --disable-dga --disable-dri --disable-xinerama \
+ --disable-xf86misc --disable-xf86vidmode \
+ --disable-xorg --disable-xorgcfg \
+ --disable-xkb --disable-xnest --disable-xvfb \
+ --disable-xevie --disable-xprint --disable-xtrap \
+ --disable-dmx \
+ --with-default-font-path=built-ins \
+ --enable-tslib --enable-xcalibrate \
+ ac_cv_file__usr_share_sgml_X11_defs_ent=no"
+
+do_configure_prepend() {
+ sed -i -e 's/tslib-0.0/tslib-1.0/' ${S}/configure.ac
+}
+
+FILES_${PN} = "${bindir}/Xglamo"
+FILES_${PN}-dbg = "${bindir}/.debug/Xglamo"
+
+ARM_INSTRUCTION_SET = "arm"