summaryrefslogtreecommitdiff
path: root/meta/packages/yum/files/paths2.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:18 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:18 +0000
commitbc6e408352af5a6c254842cb0ea74a503c9b443b (patch)
treecbf590f2fe105ed4a3cb8c815cd124368a2f8279 /meta/packages/yum/files/paths2.patch
parent559a522dc3b2c7251cee8933819f729a5aeec46d (diff)
downloadopenembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.gz
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.bz2
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.xz
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.zip
yum: fixed packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5426 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum/files/paths2.patch')
-rw-r--r--meta/packages/yum/files/paths2.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch
new file mode 100644
index 000000000..08c9c8312
--- /dev/null
+++ b/meta/packages/yum/files/paths2.patch
@@ -0,0 +1,33 @@
+---
+ rpmUtils/Makefile | 2 +-
+ yum/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- yum-3.2.18.orig/rpmUtils/Makefile
++++ yum-3.2.18/rpmUtils/Makefile
+@@ -1,10 +1,10 @@
+ PYTHON=python
+ PACKAGE = $(shell basename `pwd`)
+ PYFILES = $(wildcard *.py)
+ PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
+-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
++PYSYSDIR = /usr
+ PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
+
+ all:
+ echo "Nothing to do"
+--- yum-3.2.18.orig/yum/Makefile
++++ yum-3.2.18/yum/Makefile
+@@ -1,10 +1,10 @@
+ PYTHON=python
+ PACKAGE = $(shell basename `pwd`)
+ PYFILES = $(wildcard *.py)
+ PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
+-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
++PYSYSDIR = /usr
+ PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+ PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
+
+ all:
+ echo "Nothing to do"