summaryrefslogtreecommitdiff
path: root/meta/packages/yum/yum_3.2.18.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-10-02 14:26:24 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-10-02 14:26:24 +0000
commit94fa2b90c53ced5d6b720a57edcd290123d812d2 (patch)
treeab95598ac4bc64a9121c74598117060dd8083f46 /meta/packages/yum/yum_3.2.18.bb
parent8626cf563c9b0b46f0e04de09250fc5cc1be816d (diff)
downloadopenembedded-core-94fa2b90c53ced5d6b720a57edcd290123d812d2.tar.gz
openembedded-core-94fa2b90c53ced5d6b720a57edcd290123d812d2.tar.bz2
openembedded-core-94fa2b90c53ced5d6b720a57edcd290123d812d2.tar.xz
openembedded-core-94fa2b90c53ced5d6b720a57edcd290123d812d2.zip
yum: added 3.2.18
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5379 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum/yum_3.2.18.bb')
-rw-r--r--meta/packages/yum/yum_3.2.18.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/yum/yum_3.2.18.bb b/meta/packages/yum/yum_3.2.18.bb
new file mode 100644
index 000000000..67e9ad7b2
--- /dev/null
+++ b/meta/packages/yum/yum_3.2.18.bb
@@ -0,0 +1,24 @@
+HOMEPAGE = "http://linux.duke.edu/projects/yum/"
+
+SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
+ file://hacks.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://yum-install-recommends.py \
+ file://extract-postinst.awk"
+
+DEPENDS = "rpm python python-iniparse python-urlgrabber yum-metadata-parser libxml2"
+
+S = "${WORKDIR}/yum-${PV}"
+
+inherit autotools
+
+do_compile_append () {
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py
+}
+
+do_install_append () {
+ install -d ${D}${bindir}/
+ install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/
+ install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/
+}