summaryrefslogtreecommitdiff
path: root/meta/packages/yum/yum_3.2.18.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:18 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-10-07 09:31:18 +0000
commitbc6e408352af5a6c254842cb0ea74a503c9b443b (patch)
treecbf590f2fe105ed4a3cb8c815cd124368a2f8279 /meta/packages/yum/yum_3.2.18.bb
parent559a522dc3b2c7251cee8933819f729a5aeec46d (diff)
downloadopenembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.gz
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.bz2
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.tar.xz
openembedded-core-bc6e408352af5a6c254842cb0ea74a503c9b443b.zip
yum: fixed packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5426 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum/yum_3.2.18.bb')
-rw-r--r--meta/packages/yum/yum_3.2.18.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/packages/yum/yum_3.2.18.bb b/meta/packages/yum/yum_3.2.18.bb
index 9770a4e68..4c6880309 100644
--- a/meta/packages/yum/yum_3.2.18.bb
+++ b/meta/packages/yum/yum_3.2.18.bb
@@ -1,12 +1,14 @@
HOMEPAGE = "http://linux.duke.edu/projects/yum/"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
file://paths.patch;patch=1 \
+ file://paths2.patch;patch=1 \
file://yum-install-recommends.py \
file://extract-postinst.awk"
-DEPENDS = "rpm python python-iniparse python-urlgrabber yum-metadata-parser libxml2"
+DEPENDS = "python"
+RDEPENDS = "rpm python-core python-iniparse python-urlgrabber yum-metadata-parser"
S = "${WORKDIR}/yum-${PV}"
@@ -22,3 +24,5 @@ do_install_append () {
install ${WORKDIR}/extract-postinst.awk ${D}${bindir}/
install ${WORKDIR}/yum-install-recommends.py ${D}${bindir}/
}
+
+FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"