summaryrefslogtreecommitdiff
path: root/meta/packages/yum
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-09-03 23:20:58 +0000
committerRichard Purdie <richard@openedhand.com>2008-09-03 23:20:58 +0000
commita6f3e46936b913032ead27dd67e6fe03f03cd36c (patch)
tree17382ab6ac86691ec7b23cd295420a19b852e6e9 /meta/packages/yum
parentf9cefb630eab68f2998702baded4a2acab697caf (diff)
downloadopenembedded-core-a6f3e46936b913032ead27dd67e6fe03f03cd36c.tar.gz
openembedded-core-a6f3e46936b913032ead27dd67e6fe03f03cd36c.tar.bz2
openembedded-core-a6f3e46936b913032ead27dd67e6fe03f03cd36c.tar.xz
openembedded-core-a6f3e46936b913032ead27dd67e6fe03f03cd36c.zip
yum-native: Add extract-postinst.awk script for use during rootfs generation
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5133 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/yum')
-rw-r--r--meta/packages/yum/yum-native/extract-postinst.awk11
-rw-r--r--meta/packages/yum/yum-native_3.2.18.bb8
2 files changed, 18 insertions, 1 deletions
diff --git a/meta/packages/yum/yum-native/extract-postinst.awk b/meta/packages/yum/yum-native/extract-postinst.awk
new file mode 100644
index 000000000..8f2836b32
--- /dev/null
+++ b/meta/packages/yum/yum-native/extract-postinst.awk
@@ -0,0 +1,11 @@
+/Name:.*/ {
+ package = substr($0, 7)
+ next
+}
+/postinstall.*scriptlet .*/ {
+ next
+}
+{
+ print $0 >> ENVIRON["D"] "/etc/rpm-postinsts/" package ".sh"
+}
+
diff --git a/meta/packages/yum/yum-native_3.2.18.bb b/meta/packages/yum/yum-native_3.2.18.bb
index d90f158cd..76e92b34a 100644
--- a/meta/packages/yum/yum-native_3.2.18.bb
+++ b/meta/packages/yum/yum-native_3.2.18.bb
@@ -2,7 +2,8 @@ HOMEPAGE = "http://linux.duke.edu/projects/yum/"
SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
file://hacks.patch;patch=1 \
- file://paths.patch;patch=1"
+ file://paths.patch;patch=1 \
+ file://extract-postinst.awk"
PR = "r4"
DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native libxml2-native"
@@ -15,3 +16,8 @@ do_compile_append () {
sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py
sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py
}
+
+do_install_append () {
+ install -d ${STAGING_BINDIR}/
+ install ${WORKDIR}/extract-postinst.awk ${STAGING_BINDIR}/
+}