summaryrefslogtreecommitdiff
path: root/meta/packages/zlib/files/autotools.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-06-11 13:02:35 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-06-30 13:19:02 +0100
commitafe4dec809644c8e070dd8df929fb784e1cf37ed (patch)
treef339c40e0edb6eb1cd4e7fb24fdac3575df5a74c /meta/packages/zlib/files/autotools.patch
parent86171831d625073385c45dc59c4214bea0d9c963 (diff)
downloadopenembedded-core-afe4dec809644c8e070dd8df929fb784e1cf37ed.tar.gz
openembedded-core-afe4dec809644c8e070dd8df929fb784e1cf37ed.tar.bz2
openembedded-core-afe4dec809644c8e070dd8df929fb784e1cf37ed.tar.xz
openembedded-core-afe4dec809644c8e070dd8df929fb784e1cf37ed.zip
zlib: upgrade to version 1.2.5
from 1.2.3 update homepage and license changes: - remove 1.2.3.3 patch - breakdown autotools.patch to configure.ac and Makefile.am, update src in Makefile.am and use do_configure_prepend instead - remove README from LIC_FILES_CHKSUM because it duplicates zlib.h and also causes checksum to change for every release - remove visibility.patch: the purpose of the patch was to change "<type> ZEXPORT" to "ZEXPORT <type>", however: 1. the use of ZEXPORT and ZEXTERN have been changed a lot in zlib, there is no changelog to indicate which version was the patch based on and its rationale 2. zlib used to set default visibility to `hidden' (-fvisibility=hidden), and override external symbols with `default' visibility, it had caused a lot of problems on different platforms. But starting from 1.2.5, default visibility is now `default', `hidden' visibility override has effect only for the correct GCC versions, most visibility related issues should have already been fixed http://mail.madler.net/pipermail/zlib-devel_madler.net/2010-April/002045.html 3. as for now, ZEXPORT is used in Win/BeOS only, and can expand to WINAPI or __declspec(dllexport), both of which should be put behind return type, so there is no need to patch In conclusion, the patch is not applicable for the current release, so it's removed Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/zlib/files/autotools.patch')
-rw-r--r--meta/packages/zlib/files/autotools.patch849
1 files changed, 0 insertions, 849 deletions
diff --git a/meta/packages/zlib/files/autotools.patch b/meta/packages/zlib/files/autotools.patch
deleted file mode 100644
index c2db0848f..000000000
--- a/meta/packages/zlib/files/autotools.patch
+++ /dev/null
@@ -1,849 +0,0 @@
-Index: zlib-1.2.3/configure
-===================================================================
---- zlib-1.2.3.orig/configure 2008-08-23 11:23:47.000000000 +0100
-+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
-@@ -1,558 +0,0 @@
--#!/bin/sh
--# configure script for zlib. This script is needed only if
--# you wish to build a shared library and your system supports them,
--# of if you need special compiler, flags or install directory.
--# Otherwise, you can just use directly "make test; make install"
--#
--# To create a shared library, use "configure --shared"; by default a static
--# library is created. If the primitive shared library support provided here
--# does not work, use ftp://prep.ai.mit.edu/pub/gnu/libtool-*.tar.gz
--#
--# To impose specific compiler or flags or install directory, use for example:
--# prefix=$HOME CC=cc CFLAGS="-O4" ./configure
--# or for csh/tcsh users:
--# (setenv prefix $HOME; setenv CC cc; setenv CFLAGS "-O4"; ./configure)
--# LDSHARED is the command to be used to create a shared library
--
--# Incorrect settings of CC or CFLAGS may prevent creating a shared library.
--# If you have problems, try without defining CC and CFLAGS before reporting
--# an error.
--
--LIBS=libz.a
--LDFLAGS="-L. ${LIBS}"
--VER=`sed -n -e '/VERSION "/s/.*"\(.*\)".*/\1/p' < zlib.h`
--VER2=`sed -n -e '/VERSION "/s/.*"\([0-9]*\\.[0-9]*\)\\..*/\1/p' < zlib.h`
--VER1=`sed -n -e '/VERSION "/s/.*"\([0-9]*\)\\..*/\1/p' < zlib.h`
--AR=${AR-"ar"}
--AR_RC="${AR} rc"
--RANLIB=${RANLIB-"ranlib"}
--prefix=${prefix-/usr/local}
--exec_prefix=${exec_prefix-'${prefix}'}
--libdir=${libdir-'${exec_prefix}/lib'}
--includedir=${includedir-'${prefix}/include'}
--mandir=${mandir-'${prefix}/share/man'}
--shared_ext='.so'
--shared=1
--zprefix=0
--gcc=0
--old_cc="$CC"
--old_cflags="$CFLAGS"
--
--while test $# -ge 1
--do
--case "$1" in
-- -h* | --help)
-- echo 'usage:'
-- echo ' configure [--shared] [--prefix=PREFIX] [--exec_prefix=EXPREFIX]'
-- echo ' [--libdir=LIBDIR] [--includedir=INCLUDEDIR] [--zprefix]'
-- exit 0;;
-- -p*=* | --prefix=*) prefix=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -e*=* | --eprefix=*) exec_prefix=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -l*=* | --libdir=*) libdir=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -i*=* | --includedir=*) includedir=`echo $1 | sed 's/[-a-z_]*=//'`;shift;;
-- -u*=* | --uname=*) uname=`echo $1 | sed 's/[-a-z_]*=//'`;shift;;
-- -p* | --prefix) prefix="$2"; shift; shift;;
-- -e* | --eprefix) exec_prefix="$2"; shift; shift;;
-- -l* | --libdir) libdir="$2"; shift; shift;;
-- -i* | --includedir) includedir="$2"; shift; shift;;
-- -s* | --shared | --enable-shared) shared=1; shift;;
-- -t | --static) shared=0; shift;;
-- -z* | --zprefix) zprefix=1; shift;;
-- --sysconfdir=*) echo "ignored option: --sysconfdir"; shift;;
-- --localstatedir=*) echo "ignored option: --localstatedir"; shift;;
-- *) echo "unknown option: $1"; echo "$0 --help for help"; exit 1;;
-- esac
--done
--
--test=ztest$$
--cat > $test.c <<EOF
--extern int getchar();
--int hello() {return getchar();}
--EOF
--
--test -z "$CC" && echo Checking for gcc...
--cc=${CC-gcc}
--cflags=${CFLAGS-"-O3"}
--# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
--case "$cc" in
-- *gcc*) gcc=1;;
--esac
--
--if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
-- CC="$cc"
-- SFLAGS="${CFLAGS-"-O3"} -fPIC"
-- CFLAGS="${CFLAGS-"-O3"}"
-- if test -z $uname; then
-- uname=`(uname -s || echo unknown) 2>/dev/null`
-- fi
-- case "$uname" in
-- Linux | linux | GNU | GNU/*) LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1,--version-script,zlib.map"};;
-- CYGWIN* | Cygwin* | cygwin* | OS/2* )
-- EXE='.exe';;
-- QNX*) # This is for QNX6. I suppose that the QNX rule below is for QNX2,QNX4
-- # (alain.bonnefoy@icbt.com)
-- LDSHARED=${LDSHARED-"$cc -shared -Wl,-hlibz.so.1"};;
-- HP-UX*)
-- LDSHARED=${LDSHARED-"$cc -shared $SFLAGS"}
-- case `(uname -m || echo unknown) 2>/dev/null` in
-- ia64)
-- shared_ext='.so'
-- SHAREDLIB='libz.so';;
-- *)
-- shared_ext='.sl'
-- SHAREDLIB='libz.sl';;
-- esac;;
-- Darwin*) shared_ext='.dylib'
-- SHAREDLIB=libz$shared_ext
-- SHAREDLIBV=libz.$VER$shared_ext
-- SHAREDLIBM=libz.$VER1$shared_ext
-- LDSHARED=${LDSHARED-"$cc -dynamiclib -install_name $libdir/$SHAREDLIBM -compatibility_version $VER1 -current_version $VER"};;
-- *) LDSHARED=${LDSHARED-"$cc -shared"};;
-- esac
--else
-- # find system name and corresponding cc options
-- CC=${CC-cc}
-- if test -z $uname; then
-- uname=`(uname -sr || echo unknown) 2>/dev/null`
-- fi
-- case "$uname" in
-- HP-UX*) SFLAGS=${CFLAGS-"-O +z"}
-- CFLAGS=${CFLAGS-"-O"}
--# LDSHARED=${LDSHARED-"ld -b +vnocompatwarnings"}
-- LDSHARED=${LDSHARED-"ld -b"}
-- case `(uname -m || echo unknown) 2>/dev/null` in
-- ia64)
-- shared_ext='.so'
-- SHAREDLIB='libz.so';;
-- *)
-- shared_ext='.sl'
-- SHAREDLIB='libz.sl';;
-- esac;;
-- IRIX*) SFLAGS=${CFLAGS-"-ansi -O2 -rpath ."}
-- CFLAGS=${CFLAGS-"-ansi -O2"}
-- LDSHARED=${LDSHARED-"cc -shared -Wl,-soname,libz.so.1"};;
-- OSF1\ V4*) SFLAGS=${CFLAGS-"-O -std1"}
-- CFLAGS=${CFLAGS-"-O -std1"}
-- LDSHARED=${LDSHARED-"cc -shared -Wl,-soname,libz.so -Wl,-msym -Wl,-rpath,$(libdir) -Wl,-set_version,${VER}:1.0"};;
-- OSF1*) SFLAGS=${CFLAGS-"-O -std1"}
-- CFLAGS=${CFLAGS-"-O -std1"}
-- LDSHARED=${LDSHARED-"cc -shared -Wl,-soname,libz.so.1"};;
-- QNX*) SFLAGS=${CFLAGS-"-4 -O"}
-- CFLAGS=${CFLAGS-"-4 -O"}
-- LDSHARED=${LDSHARED-"cc"}
-- RANLIB=${RANLIB-"true"}
-- AR_RC="cc -A";;
-- SCO_SV\ 3.2*) SFLAGS=${CFLAGS-"-O3 -dy -KPIC "}
-- CFLAGS=${CFLAGS-"-O3"}
-- LDSHARED=${LDSHARED-"cc -dy -KPIC -G"};;
-- SunOS\ 5*) LDSHARED=${LDSHARED-"cc -G"}
-- case `(uname -m || echo unknown) 2>/dev/null` in
-- i86*)
-- SFLAGS=${CFLAGS-"-xpentium -fast -KPIC -R."}
-- CFLAGS=${CFLAGS-"-xpentium -fast"};;
-- *)
-- SFLAGS=${CFLAGS-"-fast -xcg92 -KPIC -R."}
-- CFLAGS=${CFLAGS-"-fast -xcg92"};;
-- esac;;
-- SunOS\ 4*) SFLAGS=${CFLAGS-"-O2 -PIC"}
-- CFLAGS=${CFLAGS-"-O2"}
-- LDSHARED=${LDSHARED-"ld"};;
-- SunStudio\ 9*) SFLAGS=${CFLAGS-"-DUSE_MMAP -fast -xcode=pic32 -xtarget=ultra3 -xarch=v9b"}
-- CFLAGS=${CFLAGS-"-DUSE_MMAP -fast -xtarget=ultra3 -xarch=v9b"}
-- LDSHARED=${LDSHARED-"cc -xarch=v9b"};;
-- UNIX_System_V\ 4.2.0)
-- SFLAGS=${CFLAGS-"-KPIC -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- UNIX_SV\ 4.2MP)
-- SFLAGS=${CFLAGS-"-Kconform_pic -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- OpenUNIX\ 5)
-- SFLAGS=${CFLAGS-"-KPIC -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- AIX*) # Courtesy of dbakker@arrayasolutions.com
-- SFLAGS=${CFLAGS-"-O -qmaxmem=8192"}
-- CFLAGS=${CFLAGS-"-O -qmaxmem=8192"}
-- LDSHARED=${LDSHARED-"xlc -G"};;
-- # send working options for other systems to support@gzip.org
-- *) SFLAGS=${CFLAGS-"-O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -shared"};;
-- esac
--fi
--
--SHAREDLIB=${SHAREDLIB-"libz$shared_ext"}
--SHAREDLIBV=${SHAREDLIBV-"libz$shared_ext.$VER"}
--SHAREDLIBM=${SHAREDLIBM-"libz$shared_ext.$VER1"}
--
--if test $shared -eq 1; then
-- echo Checking for shared library support...
-- # we must test in two steps (cc then ld), required at least on SunOS 4.x
-- if test "`($CC -c $SFLAGS $test.c) 2>&1`" = "" &&
-- test "`($LDSHARED -o $test$shared_ext $test.o) 2>&1`" = ""; then
-- LIBS="$LIBS $SHAREDLIBV"
-- echo Building shared library $SHAREDLIBV with $CC.
-- elif test -z "$old_cc" -a -z "$old_cflags"; then
-- echo No shared library support.
-- shared=0;
-- else
-- echo Tested $CC -c $SFLAGS $test.c
-- $CC -c $SFLAGS $test.c
-- echo Tested $LDSHARED -o $test$shared_ext $test.o
-- $LDSHARED -o $test$shared_ext $test.o
-- echo 'No shared library support; try without defining CC and CFLAGS'
-- shared=0;
-- fi
--fi
--if test $shared -eq 0; then
-- LDSHARED="$CC"
-- ALL="allstatic"
-- TEST="teststatic"
-- echo Building static library $LIBS version $VER with $CC.
--else
-- ALL="allstatic allshared"
-- TEST="teststatic testshared"
--fi
--
--cat > zlibdefs.h << EOF
--/* zlibdefs.h -- compile-time definitions for the zlib compression library
-- * Copyright (C) 1995-2006 Jean-loup Gailly.
-- * For conditions of distribution and use, see copyright notice in zlib.h
-- */
--
--EOF
--
--cat > $test.c <<EOF
--#include <sys/types.h>
--off64_t dummy = 0;
--EOF
--if test "`($CC -c $CFLAGS -D_LARGEFILE64_SOURCE=1 $test.c) 2>&1`" = ""; then
-- CFLAGS="${CFLAGS} -D_LARGEFILE64_SOURCE=1"
-- SFLAGS="${SFLAGS} -D_LARGEFILE64_SOURCE=1"
-- echo "Checking for off64_t... Yes."
-- echo "Checking for fseeko... Yes."
--else
-- echo "Checking for off64_t... No."
-- cat > $test.c <<EOF
--#include <stdio.h>
--int main(void) {
-- fseeko(NULL, 0, 0);
-- return 0;
--}
--EOF
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-- echo "Checking for fseeko... Yes."
-- else
-- CFLAGS="${CFLAGS} -DNO_FSEEKO"
-- SFLAGS="${SFLAGS} -DNO_FSEEKO"
-- echo "Checking for fseeko... No."
-- fi
--fi
--
--cat > $test.c <<EOF
--#include <unistd.h>
--int main() { return 0; }
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- cat >> zlibdefs.h <<EOF
--#include <sys/types.h> /* for off_t */
--#include <unistd.h> /* for SEEK_* and off_t */
--#ifdef VMS
--# include <unixio.h> /* for off_t */
--#endif
--#ifndef z_off_t
--# define z_off_t off_t
--#endif
--EOF
-- echo "Checking for unistd.h... Yes."
--else
-- echo "Checking for unistd.h... No."
--fi
--
--if test $zprefix -eq 1; then
-- sed < zconf.h "/#ifdef Z_PREFIX/s/def Z_PREFIX/ 1/" > zconf.temp.h
-- mv zconf.temp.h zconf.h
-- echo "Using z_ prefix on all symbols."
--fi
--
--cat > $test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--#include "zconf.h"
--
--int main()
--{
--#ifndef STDC
-- choke me
--#endif
--
-- return 0;
--}
--EOF
--
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()."
--
-- cat > $test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- vsnprintf(buf, sizeof(buf), fmt, ap);
-- va_end(ap);
-- return 0;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-- echo "Checking for vsnprintf() in stdio.h... Yes."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- int n;
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- n = vsnprintf(buf, sizeof(buf), fmt, ap);
-- va_end(ap);
-- return n;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of vsnprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_vsnprintf_void"
-- echo "Checking for return value of vsnprintf()... No."
-- echo " WARNING: apparently vsnprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- else
-- CFLAGS="$CFLAGS -DNO_vsnprintf"
-- echo "Checking for vsnprintf() in stdio.h... No."
-- echo " WARNING: vsnprintf() not found, falling back to vsprintf(). zlib"
-- echo " can build but will be open to possible buffer-overflow security"
-- echo " vulnerabilities."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- int n;
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- n = vsprintf(buf, fmt, ap);
-- va_end(ap);
-- return n;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of vsprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_vsprintf_void"
-- echo "Checking for return value of vsprintf()... No."
-- echo " WARNING: apparently vsprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- fi
--else
-- echo "Checking whether to use vs[n]printf() or s[n]printf()... using s[n]printf()."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- snprintf(buf, sizeof(buf), "%s", "foo");
-- return 0;
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-- echo "Checking for snprintf() in stdio.h... Yes."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- return snprintf(buf, sizeof(buf), "%s", "foo");
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of snprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_snprintf_void"
-- echo "Checking for return value of snprintf()... No."
-- echo " WARNING: apparently snprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- else
-- CFLAGS="$CFLAGS -DNO_snprintf"
-- echo "Checking for snprintf() in stdio.h... No."
-- echo " WARNING: snprintf() not found, falling back to sprintf(). zlib"
-- echo " can build but will be open to possible buffer-overflow security"
-- echo " vulnerabilities."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- return sprintf(buf, "%s", "foo");
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of sprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_sprintf_void"
-- echo "Checking for return value of sprintf()... No."
-- echo " WARNING: apparently sprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- fi
--fi
--
--cat >$test.c <<EOF
--#include <errno.h>
--int main() { return 0; }
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for errno.h... Yes."
--else
-- echo "Checking for errno.h... No."
-- CFLAGS="$CFLAGS -DNO_ERRNO_H"
--fi
--
--cat > $test.c <<EOF
--#include <sys/types.h>
--#include <sys/mman.h>
--#include <sys/stat.h>
--caddr_t hello() {
-- return mmap((caddr_t)0, (off_t)0, PROT_READ, MAP_SHARED, 0, (off_t)0);
--}
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- CFLAGS="$CFLAGS -DUSE_MMAP"
-- echo Checking for mmap support... Yes.
--else
-- echo Checking for mmap support... No.
--fi
--
--CPP=${CPP-"$CC -E"}
--case $CFLAGS in
-- *ASMV*)
-- if test "`nm $test.o | grep _hello`" = ""; then
-- CPP="$CPP -DNO_UNDERLINE"
-- echo Checking for underline in external names... No.
-- else
-- echo Checking for underline in external names... Yes.
-- fi;;
--esac
--
--rm -f $test.[co] $test $test$shared_ext
--
--# udpate Makefile
--sed < Makefile.in "
--/^CC *=/s#=.*#=$CC#
--/^CFLAGS *=/s#=.*#=$CFLAGS#
--/^SFLAGS *=/s#=.*#=$SFLAGS#
--/^LDFLAGS *=/s#=.*#=$LDFLAGS#
--/^LDSHARED *=/s#=.*#=$LDSHARED#
--/^CPP *=/s#=.*#=$CPP#
--/^LIBS *=/s#=.*#=$LIBS#
--/^SHAREDLIB *=/s#=.*#=$SHAREDLIB#
--/^SHAREDLIBV *=/s#=.*#=$SHAREDLIBV#
--/^SHAREDLIBM *=/s#=.*#=$SHAREDLIBM#
--/^AR *=/s#=.*#=$AR_RC#
--/^RANLIB *=/s#=.*#=$RANLIB#
--/^EXE *=/s#=.*#=$EXE#
--/^prefix *=/s#=.*#=$prefix#
--/^exec_prefix *=/s#=.*#=$exec_prefix#
--/^libdir *=/s#=.*#=$libdir#
--/^includedir *=/s#=.*#=$includedir#
--/^mandir *=/s#=.*#=$mandir#
--/^all: */s#:.*#: $ALL#
--/^test: */s#:.*#: $TEST#
--" > Makefile
--
--sed < zlib.pc.in "
--/^CC *=/s#=.*#=$CC#
--/^CFLAGS *=/s#=.*#=$CFLAGS#
--/^CPP *=/s#=.*#=$CPP#
--/^LDSHARED *=/s#=.*#=$LDSHARED#
--/^LIBS *=/s#=.*#=$LIBS#
--/^SHAREDLIB *=/s#=.*#=$SHAREDLIB#
--/^SHAREDLIBV *=/s#=.*#=$SHAREDLIBV#
--/^SHAREDLIBM *=/s#=.*#=$SHAREDLIBM#
--/^AR *=/s#=.*#=$AR_RC#
--/^RANLIB *=/s#=.*#=$RANLIB#
--/^EXE *=/s#=.*#=$EXE#
--/^prefix *=/s#=.*#=$prefix#
--/^exec_prefix *=/s#=.*#=$exec_prefix#
--/^libdir *=/s#=.*#=$libdir#
--/^includedir *=/s#=.*#=$includedir#
--/^mandir *=/s#=.*#=$mandir#
--/^LDFLAGS *=/s#=.*#=$LDFLAGS#
--" | sed -e "
--s/\@VERSION\@/$VER/g;
--" > zlib.pc
-Index: zlib-1.2.3/configure.ac
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ zlib-1.2.3/configure.ac 2008-08-23 12:01:15.000000000 +0100
-@@ -0,0 +1,48 @@
-+AC_INIT(zlib,1.2.3)
-+AC_CONFIG_SRCDIR(adler32.c)
-+AM_INIT_AUTOMAKE(zlibs,1.2.3)
-+
-+AC_PREREQ([2.59])
-+
-+AC_PROG_CC([gcc])
-+AC_PROG_LIBTOOL
-+
-+AC_HEADER_STDC
-+
-+zlib_save_CPPFLAGS=$CPPFLAGS
-+CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
-+AC_CHECK_TYPES(off64_t)
-+CPPFLAGS=$zlib_save_CPPFLAGS
-+
-+AC_CACHE_CHECK([whether to enable -D_LARGEFILE64_SOURCE], [zlib_cv_use_lfs64], [
-+ zlib_cv_use_lfs64=no
-+ if test "$ac_cv_type_off64_t" = "yes"; then
-+ zlib_cv_use_lfs64=yes
-+ fi
-+])
-+
-+if test "$zlib_cv_use_lfs64" = "yes"; then
-+ CPPFLAGS="$CPPFLAGS -D_LARGEFILE64_SOURCE"
-+
-+ #APR_ADDTO(CPPFLAGS, [-D_LARGEFILE64_SOURCE])
-+fi
-+
-+cat > zlibdefs.h << EOF
-+/* zlibdefs.h -- compile-time definitions for the zlib compression library
-+ * Copyright (C) 1995-2006 Jean-loup Gailly.
-+ * For conditions of distribution and use, see copyright notice in zlib.h
-+ */
-+
-+#include <sys/types.h> /* for off_t */
-+#include <unistd.h> /* for SEEK_* and off_t */
-+#ifdef VMS
-+# include <unixio.h> /* for off_t */
-+#endif
-+#ifndef z_off_t
-+# define z_off_t off_t
-+#endif
-+EOF
-+
-+AC_CONFIG_FILES([Makefile])
-+
-+AC_OUTPUT
-Index: zlib-1.2.3/Makefile.am
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ zlib-1.2.3/Makefile.am 2008-08-23 11:23:47.000000000 +0100
-@@ -0,0 +1,8 @@
-+lib_LTLIBRARIES = libz.la
-+
-+libz_la_SOURCES = adler32.c compress.c crc32.c gzio.c uncompr.c deflate.c \
-+ trees.c zutil.c inflate.c infback.c inftrees.c inffast.c
-+
-+libz_la_LDFLAGS = -version-number 1:2:3 --version-script zlib.map
-+
-+include_HEADERS = zconf.h zlib.h zlibdefs.h
-Index: zlib-1.2.3/Makefile.in
-===================================================================
---- zlib-1.2.3.orig/Makefile.in 2008-08-23 11:23:47.000000000 +0100
-+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
-@@ -1,215 +0,0 @@
--# Makefile for zlib
--# Copyright (C) 1995-2006 Jean-loup Gailly.
--# For conditions of distribution and use, see copyright notice in zlib.h
--
--# To compile and test, type:
--# ./configure; make test
--# The call of configure is optional if you don't have special requirements
--# If you wish to build zlib as a shared library, use: ./configure -s
--
--# To use the asm code, type:
--# cp contrib/asm?86/match.S ./match.S
--# make LOC=-DASMV OBJA=match.o
--
--# To install /usr/local/lib/libz.* and /usr/local/include/zlib.h, type:
--# make install
--# To install in $HOME instead of /usr/local, use:
--# make install prefix=$HOME
--
--CC=cc
--
--CFLAGS=-O
--#CFLAGS=-O -DMAX_WBITS=14 -DMAX_MEM_LEVEL=7
--#CFLAGS=-g -DDEBUG
--#CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \
--# -Wstrict-prototypes -Wmissing-prototypes
--
--SFLAGS=-O
--
--LDFLAGS=libz.a
--LDSHARED=$(CC)
--CPP=$(CC) -E
--
--LIBS=libz.a
--SHAREDLIB=libz.so
--SHAREDLIBV=libz.so.1.2.3.3
--SHAREDLIBM=libz.so.1
--
--AR=ar
--RANLIB=ranlib
--TAR=tar
--SHELL=/bin/sh
--EXE=
--
--prefix = /usr/local
--exec_prefix = ${prefix}
--libdir = ${exec_prefix}/lib
--includedir = ${prefix}/include
--mandir = ${prefix}/share/man
--man3dir = ${mandir}/man3
--pkgconfigdir = ${libdir}/pkgconfig
--
--OBJC = adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o \
-- zutil.o inflate.o infback.o inftrees.o inffast.o
--
--OBJA =
--# to use the asm code: make OBJA=match.o
--
--OBJS = $(OBJC) $(OBJA)
--
--PIC_OBJS = $(OBJS:%.o=%.lo)
--
--TEST_OBJS = example.o minigzip.o
--
--allstatic: example$(EXE) minigzip$(EXE)
--
--allshared: examplesh$(EXE) minigzipsh$(EXE)
--
--all: allstatic allshared
--
--teststatic: allstatic
-- @echo hello world | ./minigzip | ./minigzip -d || \
-- echo ' *** minigzip test FAILED ***' ; \
-- if ./example; then \
-- echo ' *** zlib test OK ***'; \
-- else \
-- echo ' *** zlib test FAILED ***'; \
-- fi
--
--testshared: allshared
-- @LD_LIBRARY_PATH=`pwd`:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
-- DYLD_LIBRARY_PATH=`pwd`:$(DYLD_LIBRARY_PATH) ; export DYLD_LIBRARY_PATH; \
-- SHLIB_PATH=`pwd`:$(SHLIB_PATH) ; export SHLIB_PATH; \
-- echo hello world | ./minigzipsh | ./minigzipsh -d || \
-- echo ' *** minigzip shared test FAILED ***' ; \
-- if ./examplesh; then \
-- echo ' *** zlib shared test OK ***'; \
-- else \
-- echo ' *** zlib shared test FAILED ***'; \
-- fi
--
--test: teststatic testshared
--
--check: test
--
--libz.a: $(OBJS)
-- $(AR) $@ $(OBJS)
-- -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
--
--match.o: match.S
-- $(CPP) match.S > _match.s
-- $(CC) -c _match.s
-- mv _match.o match.o
-- rm -f _match.s
--
--match.lo: match.S
-- $(CPP) match.S > _match.s
-- $(CC) -c -fPIC _match.s
-- mv _match.o match.lo
-- rm -f _match.s
--
--%.lo: %.c
-- $(CC) $(SFLAGS) -DPIC -c $< -o $@
--
--$(SHAREDLIBV): $(PIC_OBJS)
-- $(LDSHARED) -o $@ $(PIC_OBJS) -lc
-- rm -f $(SHAREDLIB) $(SHAREDLIBM)
-- ln -s $@ $(SHAREDLIB)
-- ln -s $@ $(SHAREDLIBM)
--
--example$(EXE): example.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS)
--
--minigzip$(EXE): minigzip.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
--
--examplesh$(EXE): example.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ example.o -L. $(SHAREDLIB)
--
--minigzipsh$(EXE): minigzip.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ minigzip.o -L. $(SHAREDLIB)
--
--install-libs: $(LIBS)
-- -@if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir -p $(DESTDIR)$(exec_prefix); fi
-- -@if [ ! -d $(DESTDIR)$(libdir) ]; then mkdir -p $(DESTDIR)$(libdir); fi
-- -@if [ ! -d $(DESTDIR)$(man3dir) ]; then mkdir -p $(DESTDIR)$(man3dir); fi
-- -@if [ ! -d $(DESTDIR)$(pkgconfigdir) ]; then mkdir -p $(DESTDIR)$(pkgconfigdir); fi
-- cp $(LIBS) $(DESTDIR)$(libdir)
-- cd $(DESTDIR)$(libdir); chmod 755 $(LIBS)
-- -@(cd $(DESTDIR)$(libdir); $(RANLIB) libz.a || true) >/dev/null 2>&1
-- cd $(DESTDIR)$(libdir); if test -f $(SHAREDLIBV); then \
-- rm -f $(SHAREDLIB) $(SHAREDLIBM); \
-- ln -s $(SHAREDLIBV) $(SHAREDLIB); \
-- ln -s $(SHAREDLIBV) $(SHAREDLIBM); \
-- (ldconfig || true) >/dev/null 2>&1; \
-- fi
-- cp zlib.3 $(DESTDIR)$(man3dir)
-- chmod 644 $(DESTDIR)$(man3dir)/zlib.3
-- cp zlib.pc $(DESTDIR)$(pkgconfigdir)
-- chmod 644 $(DESTDIR)$(pkgconfigdir)/zlib.pc
--# The ranlib in install is needed on NeXTSTEP which checks file times
--# ldconfig is for Linux
--
--install: install-libs
-- -@if [ ! -d $(DESTDIR)$(includedir) ]; then mkdir -p $(DESTDIR)$(includedir); fi
-- cp zlib.h zconf.h zlibdefs.h $(DESTDIR)$(includedir)
-- chmod 644 $(DESTDIR)$(includedir)/zlib.h $(DESTDIR)$(includedir)/zconf.h $(DESTDIR)$(includedir)/zlibdefs.h
--
--uninstall:
-- cd $(DESTDIR)$(includedir); rm -f zlib.h zconf.h zlibdefs.h
-- cd $(DESTDIR)$(libdir); rm -f libz.a; \
-- if test -f $(SHAREDLIBV); then \
-- rm -f $(SHAREDLIBV) $(SHAREDLIB) $(SHAREDLIBM); \
-- fi
-- cd $(DESTDIR)$(man3dir); rm -f zlib.3
-- cd $(DESTDIR)$(pkgconfigdir); rm -f zlib.pc
--
--mostlyclean: clean
--clean:
-- rm -f *.o *.lo *~ \
-- example$(EXE) minigzip$(EXE) examplesh$(EXE) minigzipsh$(EXE) \
-- libz.* foo.gz so_locations \
-- _match.s maketree contrib/infback9/*.o
--
--maintainer-clean: distclean
--distclean: clean
-- cp -p Makefile.in Makefile
-- rm zlibdefs.h
-- touch -r configure zlibdefs.h
-- rm -f zlib.pc .DS_Store
--
--tags:
-- etags *.[ch]
--
--depend:
-- makedepend -- $(CFLAGS) -- *.[ch]
--
--# DO NOT DELETE THIS LINE -- make depend depends on it.
--
--adler32.o: zlib.h zconf.h zlibdefs.h
--compress.o: zlib.h zconf.h zlibdefs.h
--crc32.o: crc32.h zlib.h zconf.h zlibdefs.h
--deflate.o: deflate.h zutil.h zlib.h zconf.h zlibdefs.h
--example.o: zlib.h zconf.h zlibdefs.h
--gzio.o: zutil.h zlib.h zconf.h zlibdefs.h
--inffast.o: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h
--inflate.o: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h inffixed.h
--infback.o: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h inffixed.h
--inftrees.o: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h
--minigzip.o: zlib.h zconf.h zlibdefs.h
--trees.o: deflate.h zutil.h zlib.h zconf.h zlibdefs.h trees.h
--uncompr.o: zlib.h zconf.h zlibdefs.h
--zutil.o: zutil.h zlib.h zconf.h zlibdefs.h
--
--adler32.lo: zlib.h zconf.h zlibdefs.h
--compress.lo: zlib.h zconf.h zlibdefs.h
--crc32.lo: crc32.h zlib.h zconf.h zlibdefs.h
--deflate.lo: deflate.h zutil.h zlib.h zconf.h zlibdefs.h
--gzio.lo: zutil.h zlib.h zconf.h zlibdefs.h
--inffast.lo: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h
--inflate.lo: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h inffixed.h
--infback.lo: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h inflate.h inffast.h inffixed.h
--inftrees.lo: zutil.h zlib.h zconf.h zlibdefs.h inftrees.h
--trees.lo: deflate.h zutil.h zlib.h zconf.h zlibdefs.h trees.h
--uncompr.lo: zlib.h zconf.h zlibdefs.h
--zutil.lo: zutil.h zlib.h zconf.h zlibdefs.h