summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-17 16:08:13 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-17 16:08:13 +0000
commit15f5842bcba831a6e8c4330ad0ad93066ee02b5f (patch)
treed0c7d0f6d4f56255da3dea1947435c47e8553479 /meta/packages
parentd065e28d1f03f5ee1805d1ff6782333e9ccfcc8e (diff)
downloadopenembedded-core-15f5842bcba831a6e8c4330ad0ad93066ee02b5f.tar.gz
openembedded-core-15f5842bcba831a6e8c4330ad0ad93066ee02b5f.tar.bz2
openembedded-core-15f5842bcba831a6e8c4330ad0ad93066ee02b5f.tar.xz
openembedded-core-15f5842bcba831a6e8c4330ad0ad93066ee02b5f.zip
matchbox-wm: added 1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1517 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_1.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm_1.2.bb b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
new file mode 100644
index 000000000..82ba5221c
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm_1.2.bb
@@ -0,0 +1,36 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
+RDEPENDS = "matchbox-common"
+
+SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
+ file://kbdconfig \
+ file://gconf-2.m4"
+
+S = "${WORKDIR}/matchbox-window-manager-${PV}"
+
+inherit autotools pkgconfig update-alternatives
+
+FILES_${PN} = "${bindir}/* \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+EXTRA_OECONF = " --enable-startup-notification --disable-xrm"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/gconf-2.m4 ${S}/
+}
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+