summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-12 10:03:29 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-12 10:03:29 +0000
commit2d6eba7b17be4b4ae37b8c92b0332909fbd63637 (patch)
tree15b7dba27c48773ab92b353756fb4711493637a8 /meta/packages
parent15389d643ec6b12ebe84c0455aa4613b4c893a34 (diff)
downloadopenembedded-core-2d6eba7b17be4b4ae37b8c92b0332909fbd63637.tar.gz
openembedded-core-2d6eba7b17be4b4ae37b8c92b0332909fbd63637.tar.bz2
openembedded-core-2d6eba7b17be4b4ae37b8c92b0332909fbd63637.tar.xz
openembedded-core-2d6eba7b17be4b4ae37b8c92b0332909fbd63637.zip
gcc(-cross): move zecke-no-host-includes.patch only to cross version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1482 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/gcc/gcc-cross_4.1.1.bb4
-rw-r--r--meta/packages/gcc/gcc_4.1.1.bb5
2 files changed, 5 insertions, 4 deletions
diff --git a/meta/packages/gcc/gcc-cross_4.1.1.bb b/meta/packages/gcc/gcc-cross_4.1.1.bb
index 42e9d151b..62499f8ee 100644
--- a/meta/packages/gcc/gcc-cross_4.1.1.bb
+++ b/meta/packages/gcc/gcc-cross_4.1.1.bb
@@ -5,7 +5,7 @@ inherit cross
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
# NOTE: split PR. If the main .oe changes something that affects its *build*
# remember to increment this one too.
-PR = "r11"
+PR = "r12"
DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
@@ -16,3 +16,5 @@ require gcc3-build-cross.inc
require gcc-package-cross.inc
EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/meta/packages/gcc/gcc_4.1.1.bb b/meta/packages/gcc/gcc_4.1.1.bb
index e32353325..ea99e8bcb 100644
--- a/meta/packages/gcc/gcc_4.1.1.bb
+++ b/meta/packages/gcc/gcc_4.1.1.bb
@@ -1,4 +1,4 @@
-PR = "r9"
+PR = "r10"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
@@ -31,10 +31,9 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
file://unbreak-armv4t.patch;patch=1 \
file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
file://gcc-4.1.1-pr13685-1.patch;patch=1 \
+ file://gcc-ignore-cache.patch;patch=1 \
"
-SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-
#Set the fortran bits
# 'fortran' or '', not 'f77' like gcc3 had
FORTRAN = ""