summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-19 17:07:42 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-19 17:07:42 +0100
commit331cd032016cec032504ae7065cc297ba086a1d0 (patch)
tree473f31b2302c0b6165956833345d6e15e2d6aee7 /meta/packages
parente8618a110338bf9bc200013a370d92f957956460 (diff)
downloadopenembedded-core-331cd032016cec032504ae7065cc297ba086a1d0.tar.gz
openembedded-core-331cd032016cec032504ae7065cc297ba086a1d0.tar.bz2
openembedded-core-331cd032016cec032504ae7065cc297ba086a1d0.tar.xz
openembedded-core-331cd032016cec032504ae7065cc297ba086a1d0.zip
gobject-introspection: Update revision
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/gnome/gobject-introspection/configure.patch25
-rw-r--r--meta/packages/gnome/gobject-introspection/pathfix.patch37
-rw-r--r--meta/packages/gnome/gobject-introspection_git.bb6
3 files changed, 41 insertions, 27 deletions
diff --git a/meta/packages/gnome/gobject-introspection/configure.patch b/meta/packages/gnome/gobject-introspection/configure.patch
new file mode 100644
index 000000000..c441799b2
--- /dev/null
+++ b/meta/packages/gnome/gobject-introspection/configure.patch
@@ -0,0 +1,25 @@
+Index: git/common.mk
+===================================================================
+--- git.orig/common.mk 2009-08-19 11:11:26.000000000 +0100
++++ git/common.mk 2009-08-19 11:12:05.000000000 +0100
+@@ -4,7 +4,7 @@
+ UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir) \
+ UNINSTALLED_INTROSPECTION_BUILDDIR=$(top_builddir)
+ SCANNER_ARGS = -v --add-include-path=$(top_builddir)/gir --add-include-path=.
+-SCANNER = $(AM_V_GEN) env LPATH=.libs $(CHECK_DEBUG) $(SCANNER_ENV) $(SCANNER_BIN) $(SCANNER_ARGS)
++SCANNER = $(AM_V_GEN) env LPATH=.libs $(CHECK_DEBUG) $(SCANNER_ENV) g-ir-scanner $(SCANNER_ARGS)
+ SCANNER_LIBS = \
+ $(top_srcdir)/giscanner/*.py \
+ $(top_builddir)/giscanner/libgiscanner.la \
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2009-08-19 11:11:26.000000000 +0100
++++ git/configure.ac 2009-08-19 11:11:28.000000000 +0100
+@@ -201,7 +201,6 @@
+ pyexecdir=`echo $pyexecdir | tr '\\\\' '/'`
+ ;;
+ esac
+-AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+
+ AC_CONFIG_FILES([
+ Makefile
diff --git a/meta/packages/gnome/gobject-introspection/pathfix.patch b/meta/packages/gnome/gobject-introspection/pathfix.patch
index d640ddba1..b4582e2ea 100644
--- a/meta/packages/gnome/gobject-introspection/pathfix.patch
+++ b/meta/packages/gnome/gobject-introspection/pathfix.patch
@@ -1,22 +1,22 @@
Index: git/gir/Makefile.am
===================================================================
---- git.orig/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
-+++ git/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
-@@ -40,7 +40,7 @@
+--- git.orig/gir/Makefile.am 2009-08-19 11:11:26.000000000 +0100
++++ git/gir/Makefile.am 2009-08-19 11:12:45.000000000 +0100
+@@ -41,7 +41,7 @@
-I$(GLIB_LIBDIR)/glib-2.0/include \
-DGETTEXT_PACKAGE=Dummy \
-D__G_I18N_LIB_H__ \
- $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
+ $(GLIB_INCLUDEDIR)/glibconfig.h \
$(srcdir)/glib-2.0.c \
+ -DGLIB_COMPILATION \
$(GLIB_INCLUDEDIR)/glib/*.h
- $(SCANNER) $(SCANNER_ARGS) \
Index: git/giscanner/dumper.py
===================================================================
---- git.orig/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
-+++ git/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
-@@ -79,7 +79,7 @@
- self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect')
+--- git.orig/giscanner/dumper.py 2009-08-19 11:11:26.000000000 +0100
++++ git/giscanner/dumper.py 2009-08-19 11:12:45.000000000 +0100
+@@ -82,7 +82,7 @@
+ self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect', dir=os.getcwd())
self._compiler_cmd = os.environ.get('CC', 'gcc')
- self._linker_cmd = os.environ.get('LD', self._compiler_cmd)
@@ -26,9 +26,9 @@ Index: git/giscanner/dumper.py
self._uninst_srcdir = os.environ.get(
Index: git/giscanner/scannermain.py
===================================================================
---- git.orig/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
-+++ git/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
-@@ -282,6 +282,7 @@
+--- git.orig/giscanner/scannermain.py 2009-08-19 11:11:26.000000000 +0100
++++ git/giscanner/scannermain.py 2009-08-19 11:12:45.000000000 +0100
+@@ -283,6 +283,7 @@
shown_include_warning = False
for include in options.includes:
if os.sep in include:
@@ -36,18 +36,3 @@ Index: git/giscanner/scannermain.py
raise ValueError("Invalid include path %r" % (include, ))
include_obj = Include.from_string(include)
transformer.register_include(include_obj)
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac 2009-05-12 14:37:40.000000000 +0100
-+++ git/configure.ac 2009-05-12 14:38:01.000000000 +0100
-@@ -191,7 +191,9 @@
- esac
- AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
-
--SHAVE_INIT([scripts])
-+SHAVE_SAVED_LIBTOOL=$LIBTOOL
-+AC_SUBST(SHAVE_SAVED_LIBTOOL)
-+
- AC_CONFIG_FILES([
- Makefile
- gir/Makefile
diff --git a/meta/packages/gnome/gobject-introspection_git.bb b/meta/packages/gnome/gobject-introspection_git.bb
index e098044ec..9c3201cbd 100644
--- a/meta/packages/gnome/gobject-introspection_git.bb
+++ b/meta/packages/gnome/gobject-introspection_git.bb
@@ -1,8 +1,12 @@
SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+ file://configure.patch;patch=1 \
file://pathfix.patch;patch=1"
+SRC_URI_virtclass-native = "git://git.gnome.org/gobject-introspection;protocol=git \
+ file://pathfix.patch;patch=1"
+
PV = "0.0+git${SRCREV}"
-PR = "r1"
+PR = "r3"
S = "${WORKDIR}/git"