summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-10-08 09:55:48 +0000
committerRichard Purdie <richard@openedhand.com>2008-10-08 09:55:48 +0000
commit3abb77959d4ba844e219d84752cbff7d8d2c26f9 (patch)
tree09afee0ac2d90c6b207425bdc3d2d7ca4c24d2c3 /meta/packages
parent0223c7c8c2c4e83587ca92cb7e7ba8b4edb77c52 (diff)
downloadopenembedded-core-3abb77959d4ba844e219d84752cbff7d8d2c26f9.tar.gz
openembedded-core-3abb77959d4ba844e219d84752cbff7d8d2c26f9.tar.bz2
openembedded-core-3abb77959d4ba844e219d84752cbff7d8d2c26f9.tar.xz
openembedded-core-3abb77959d4ba844e219d84752cbff7d8d2c26f9.zip
linux-omap-2.6.24.7: Fix compile failure
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5449 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch34
-rw-r--r--meta/packages/linux/linux-omap_2.6.24.7.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch b/meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch
new file mode 100644
index 000000000..362368a6c
--- /dev/null
+++ b/meta/packages/linux/linux-omap-2.6.24.7/fixes2.patch
@@ -0,0 +1,34 @@
+Index: linux-2.6.24/drivers/video/omap/omap_disp_out.c
+===================================================================
+--- linux-2.6.24.orig/drivers/video/omap/omap_disp_out.c 2008-10-08 10:53:04.000000000 +0100
++++ linux-2.6.24/drivers/video/omap/omap_disp_out.c 2008-10-08 10:53:57.000000000 +0100
+@@ -1020,6 +1020,7 @@
+ else
+ return -EINVAL;
+
++#ifdef CONFIG_OMAP2_TV
+ if (out_dev == OMAP2_OUTPUT_TV) {
+ if (tv_in_use == 0) {
+ h4_i2c_tvout_on(NULL);
+@@ -1027,6 +1028,7 @@
+ tv_in_use = 1;
+ }
+ }
++#endif
+
+ if(omap2_disp_get_output_dev(layer) == out_dev)
+ return count;
+@@ -1050,11 +1052,13 @@
+ (omap2_disp_get_output_dev(OMAP2_VIDEO1) == OMAP2_OUTPUT_LCD) &&
+ (omap2_disp_get_output_dev(OMAP2_VIDEO2) == OMAP2_OUTPUT_LCD))
+ {
++#ifdef CONFIG_OMAP2_TV
+ if (tv_in_use != 0) {
+ omap2_disp_disable_output_dev(OMAP2_OUTPUT_TV);
+ h4_i2c_tvout_off(NULL);
+ tv_in_use = 0;
+ }
++#endif
+ }
+
+ return count;
diff --git a/meta/packages/linux/linux-omap_2.6.24.7.bb b/meta/packages/linux/linux-omap_2.6.24.7.bb
index 5baa320e1..e04e5677f 100644
--- a/meta/packages/linux/linux-omap_2.6.24.7.bb
+++ b/meta/packages/linux/linux-omap_2.6.24.7.bb
@@ -1,6 +1,6 @@
require linux-omap.inc
-PR = "r2"
+PR = "r3"
COMPATIBLE_MACHINE = "omap-3430ldp|omap-3430sdp"
DEFAULT_PREFERENCE = "1"
@@ -14,6 +14,7 @@ SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
http://kernel.org/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1 \
file://linux-2.6.24.7-ldp-v1.4.patch.gz;patch=1 \
file://fixes.patch;patch=1 \
+ file://fixes2.patch;patch=1 \
file://module_fix.patch;patch=1 \
file://defconfig-${MACHINE}"