summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-06-07 01:07:18 +0000
committerRobert Bragg <bob@openedhand.com>2008-06-07 01:07:18 +0000
commit3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5 (patch)
tree7281131edef59e5bdbe6c7281751eaa51d7d37f5 /meta/packages
parentdd5ed4b3ada9581b72f493b5d3e9b774d9b4e7bc (diff)
downloadopenembedded-core-3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5.tar.gz
openembedded-core-3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5.tar.bz2
openembedded-core-3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5.tar.xz
openembedded-core-3dbb2c002e38ef34918c2fc7114aa903f8fe9ec5.zip
Newer versions of gcc have multiple internal header directories and when
glibc builds using -nostdinc, it must also add all these internal directories via -system. This adds a patch to make sure the toolchain's "include-fixed" directory gets included in glibc_2.5 builds (if it exists) git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4612 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch54
-rw-r--r--meta/packages/glibc/glibc_2.5.bb3
2 files changed, 56 insertions, 1 deletions
diff --git a/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch b/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch
new file mode 100644
index 000000000..a8e87609f
--- /dev/null
+++ b/meta/packages/glibc/glibc-2.4/glibc-include-fixed.patch
@@ -0,0 +1,54 @@
+With the -nostdinc that we get --with-headers, we need to pull in GCC
+4.3's include-fixed subdir too, because that's what contains limits.h
+and syslimits.h now.
+
+
+for ChangeLog
+2008-01-30 Alexandre Oliva <aoliva@redhat.com>
+
+ * configure.in (SYSINCLUDES): Add GCC's include-fixed after include.
+ * configure: Rebuilt.
+
+Index: configure
+===================================================================
+--- configure.orig 2008-01-30 15:40:55.000000000 -0200
++++ configure 2008-01-31 03:24:36.000000000 -0200
+@@ -5066,7 +5066,12 @@ echo "$as_me: WARNING:
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+ ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ if test -d "${ccheaders}-fixed"; then
++ fixedccheaders="-isystem ${ccheaders}-fixed"
++ else
++ fixedccheaders=
++ fi
++ SYSINCLUDES="-nostdinc -isystem $ccheaders $fixedccheaders \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&5` &&
+Index: configure.in
+===================================================================
+--- configure.in.orig 2008-01-30 15:40:55.000000000 -0200
++++ configure.in 2008-01-31 03:24:30.000000000 -0200
+@@ -915,7 +915,12 @@ test -n "$aux_missing" && AC_MSG_WARN([
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+ ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ if test -d "${ccheaders}-fixed"; then
++ fixedccheaders="-isystem ${ccheaders}-fixed"
++ else
++ fixedccheaders=
++ fi
++ SYSINCLUDES="-nostdinc -isystem $ccheaders $fixedccheaders \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
+
+--
+Alexandre Oliva http://www.lsd.ic.unicamp.br/~oliva/
+FSF Latin America Board Member http://www.fsfla.org/
+Red Hat Compiler Engineer aoliva@{redhat.com, gcc.gnu.org}
+Free Software Evangelist oliva@{lsd.ic.unicamp.br, gnu.org}
+
diff --git a/meta/packages/glibc/glibc_2.5.bb b/meta/packages/glibc/glibc_2.5.bb
index cfb1974b2..8a46d2fb8 100644
--- a/meta/packages/glibc/glibc_2.5.bb
+++ b/meta/packages/glibc/glibc_2.5.bb
@@ -54,7 +54,8 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/glibc/glibc-${PV}.tar.bz2 \
file://generic-bits_time.h \
file://etc/ld.so.conf \
file://generate-supported.mk \
- file://glibc-arm-no-procinfo_h.patch;patch=1"
+ file://glibc-arm-no-procinfo_h.patch;patch=1 \
+ file://glibc-include-fixed.patch;patch=1;pnum=0"
# Build fails on sh3 and sh4 without additional patches