summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-11 10:25:26 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-11 10:25:26 +0000
commit54d555505e839bdb9122174a843e98990e9c9096 (patch)
tree19282da2e34a32a9aed3474a761d5fc2bfc724c4 /meta/packages
parente87e94bdefe0e4d6a3180c65f655ce650094b3af (diff)
downloadopenembedded-core-54d555505e839bdb9122174a843e98990e9c9096.tar.gz
openembedded-core-54d555505e839bdb9122174a843e98990e9c9096.tar.bz2
openembedded-core-54d555505e839bdb9122174a843e98990e9c9096.tar.xz
openembedded-core-54d555505e839bdb9122174a843e98990e9c9096.zip
qemu-helper: Fix symlinks
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3738 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/qemu/qemu-helper-sdk_1.0.bb20
1 files changed, 9 insertions, 11 deletions
diff --git a/meta/packages/qemu/qemu-helper-sdk_1.0.bb b/meta/packages/qemu/qemu-helper-sdk_1.0.bb
index 4e3a15b76..49136c7db 100644
--- a/meta/packages/qemu/qemu-helper-sdk_1.0.bb
+++ b/meta/packages/qemu/qemu-helper-sdk_1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Qemu helper scripts from Poky"
LICENSE = "GPL"
RDEPENDS = "qemu-sdk"
-PR = "r5"
+PR = "r6"
FILESPATH = "${FILE_DIRNAME}/qemu-helper"
@@ -17,20 +17,18 @@ inherit sdk
do_compile() {
${CC} raw2flash.c -o raw2flash.spitz
- ln -fs raw2flash.spitz raw2flash.akita
- ln -fs raw2flash.spitz raw2flash.borzoi
- ln -fs raw2flash.spitz raw2flash.terrier
${CC} raw2flash.c -o flash2raw.spitz -Dflash2raw
- ln -fs flash2raw.spitz flash2raw.akita
- ln -fs flash2raw.spitz flash2raw.borzoi
- ln -fs flash2raw.spitz flash2raw.terrier
}
do_install() {
install -d ${D}${bindir}
install -m 0755 poky-* ${D}${bindir}/
- install -m 0755 *.akita ${D}${bindir}/
- install -m 0755 *.spitz ${D}${bindir}/
- install -m 0755 *.borzoi ${D}${bindir}/
- install -m 0755 *.terrier ${D}${bindir}/
+ install raw2flash.spitz ${D}${bindir}/
+ install flash2raw.spitz ${D}${bindir}/
+ ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.akita
+ ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.borzoi
+ ln -fs raw2flash.spitz ${D}${bindir}/raw2flash.terrier
+ ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.akita
+ ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.borzoi
+ ln -fs flash2raw.spitz ${D}${bindir}/flash2raw.terrier
}