summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@openedhand.com>2008-09-22 19:02:30 +0000
committerSamuel Ortiz <sameo@openedhand.com>2008-09-22 19:02:30 +0000
commit7178ed1a629aad0288920a87474a35988d906b1c (patch)
tree58866cd31cb53d92d02a879cb32d8e515a6e004c /meta/packages
parent08012fd9637363a3d18b813b94f760ce602b621f (diff)
downloadopenembedded-core-7178ed1a629aad0288920a87474a35988d906b1c.tar.gz
openembedded-core-7178ed1a629aad0288920a87474a35988d906b1c.tar.bz2
openembedded-core-7178ed1a629aad0288920a87474a35988d906b1c.tar.xz
openembedded-core-7178ed1a629aad0288920a87474a35988d906b1c.zip
connman: Initial poky commit
We're adding both connman the daemon and connman-gnome which is a gnome applet. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5225 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/connman/connman-gnome_git.bb16
-rw-r--r--meta/packages/connman/connman_git.bb48
-rwxr-xr-xmeta/packages/connman/files/connman42
3 files changed, 106 insertions, 0 deletions
diff --git a/meta/packages/connman/connman-gnome_git.bb b/meta/packages/connman/connman-gnome_git.bb
new file mode 100644
index 000000000..59c5675b3
--- /dev/null
+++ b/meta/packages/connman/connman-gnome_git.bb
@@ -0,0 +1,16 @@
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SUMMARY = "Moblin Glib D-Bus integration"
+LICENSE = "GPL LGPL"
+PV = "0.0+git${SRCREV}"
+S = "${WORKDIR}/git"
+
+RDEPENDS = "connman"
+
+SRC_URI = "git://moblin.org/repos/projects/connman-gnome.git;protocol=http"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${datadir}/icons/hicolor/22x22/apps \
+ ${bindir}/* \
+ ${top_builddir}/common \
+ ${sysconfdir}/xdg "
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb
new file mode 100644
index 000000000..e8ad21ef9
--- /dev/null
+++ b/meta/packages/connman/connman_git.bb
@@ -0,0 +1,48 @@
+HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
+SUMMARY = "Moblin Connection Manager"
+PV = "0.0+git${SRCREV}"
+PR = "r4"
+S = "${WORKDIR}/git"
+LICENSE = "GPL"
+
+DEPENDS = "libgdbus dbus glib-2.0 hal"
+RDEPENDS = "dhcp-client wpa-supplicant resolvconf"
+
+EXTRA_OECONF += " \
+ ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \
+ ac_cv_path_DHCLIENT=/sbin/dhclient "
+
+SRC_URI = "git://moblin.org/repos/projects/connman.git;protocol=http \
+ file://connman "
+
+INITSCRIPT_NAME = "connman"
+INITSCRIPT_PARAMS = "defaults 22"
+
+inherit autotools pkgconfig update-rc.d
+
+do_install_append() {
+ install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES += "${PN}-script-dhclient"
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers \
+ ${datadir}/dbus-1/system-services/*"
+FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*"
+FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
+ ${libdir}/connman/scripts/.debug"
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/meta/packages/connman/files/connman b/meta/packages/connman/files/connman
new file mode 100755
index 000000000..5e0f90e8c
--- /dev/null
+++ b/meta/packages/connman/files/connman
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+do_start() {
+ connmand
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0