summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 11:52:46 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-10-25 11:52:46 +0000
commit74beec7beb3c730818891818be1e7b525eb001b5 (patch)
tree2133c8ee4f7eede573c01e67a214133861da2d81 /meta/packages
parent52b64ddf61a38940e5ae7675f9dfedc3253e39cc (diff)
downloadopenembedded-core-74beec7beb3c730818891818be1e7b525eb001b5.tar.gz
openembedded-core-74beec7beb3c730818891818be1e7b525eb001b5.tar.bz2
openembedded-core-74beec7beb3c730818891818be1e7b525eb001b5.tar.xz
openembedded-core-74beec7beb3c730818891818be1e7b525eb001b5.zip
bash: sync with OE (no package changes)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2959 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/bash/bash.inc26
-rw-r--r--meta/packages/bash/bash_3.2.bb27
2 files changed, 28 insertions, 25 deletions
diff --git a/meta/packages/bash/bash.inc b/meta/packages/bash/bash.inc
new file mode 100644
index 000000000..80aedfa1c
--- /dev/null
+++ b/meta/packages/bash/bash.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "An sh-compatible command language interpreter."
+HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+DEPENDS = "ncurses"
+SECTION = "base/shell"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+PARALLEL_MAKE = ""
+
+bindir = "/bin"
+sbindir = "/sbin"
+
+EXTRA_OECONF = "--with-ncurses"
+export CC_FOR_BUILD = "${BUILD_CC}"
+
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+pkg_postinst () {
+ touch ${sysconfdir}/shells
+ grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
+ grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
+}
diff --git a/meta/packages/bash/bash_3.2.bb b/meta/packages/bash/bash_3.2.bb
index e3d6b0560..8e0293e00 100644
--- a/meta/packages/bash/bash_3.2.bb
+++ b/meta/packages/bash/bash_3.2.bb
@@ -1,28 +1,5 @@
-DESCRIPTION = "An sh-compatible command language interpreter."
-HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-DEPENDS = "ncurses"
-SECTION = "base/shell"
-LICENSE = "GPL"
+require bash.inc
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
file://001-005.patch;patch=1"
-
-inherit autotools gettext
-
-PARALLEL_MAKE = ""
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-EXTRA_OECONF = "--with-ncurses"
-export CC_FOR_BUILD = "${BUILD_CC}"
-
-do_configure () {
- gnu-configize
- oe_runconf
-}
-
-pkg_postinst () {
- grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
- grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
-}