summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
commit7676c2b38e649b294bc1332839b3c3a26489dd34 (patch)
tree6de7024701603e068251830108c09954ef36db4b /meta/packages
parent2188cf09e11398447a6e59ee8a2819877f90b45c (diff)
downloadopenembedded-core-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.gz
openembedded-core-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.bz2
openembedded-core-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.xz
openembedded-core-7676c2b38e649b294bc1332839b3c3a26489dd34.zip
Move ubootchart to meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3072 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/ubootchart/files/pass-args.patch21
-rw-r--r--meta/packages/ubootchart/files/sysvinit.patch12
-rw-r--r--meta/packages/ubootchart/files/ubootchart-stop3
-rw-r--r--meta/packages/ubootchart/files/ubootchart.desktop6
-rw-r--r--meta/packages/ubootchart/ubootchart_svn.bb38
5 files changed, 80 insertions, 0 deletions
diff --git a/meta/packages/ubootchart/files/pass-args.patch b/meta/packages/ubootchart/files/pass-args.patch
new file mode 100644
index 000000000..9ad4282f2
--- /dev/null
+++ b/meta/packages/ubootchart/files/pass-args.patch
@@ -0,0 +1,21 @@
+Index: ubootchartd
+===================================================================
+--- ubootchartd (revision 9)
++++ ubootchartd (working copy)
+@@ -7,9 +7,11 @@
+ # can read.
+ . /etc/ubootchart/ubootchart.conf
+
+-####################################################
+-# Now start capturing the stats:
+-####################################################
+-/sbin/ubootchartd_bin &
+-exec $init_prog
++if [ $$ -eq 1 ]; then
++ ####################################################
++ # Now start capturing the stats:
++ ####################################################
++ /sbin/ubootchartd_bin &
++fi
+
++exec $init_prog "$@"
diff --git a/meta/packages/ubootchart/files/sysvinit.patch b/meta/packages/ubootchart/files/sysvinit.patch
new file mode 100644
index 000000000..de9fb0b17
--- /dev/null
+++ b/meta/packages/ubootchart/files/sysvinit.patch
@@ -0,0 +1,12 @@
+Index: ubootchart.conf
+===================================================================
+--- ubootchart.conf (revision 9)
++++ ubootchart.conf (working copy)
+@@ -1,6 +1,6 @@
+
+ # If you want to chain on and run somthing other than /sbin/init...
+-export init_prog=/sbin/init
++export init_prog=/sbin/init.sysvinit
+
+ # On startup ubootchart will mount a tmpfs filesystem at this
+ # location and chdir here. This is only used for the logging of
diff --git a/meta/packages/ubootchart/files/ubootchart-stop b/meta/packages/ubootchart/files/ubootchart-stop
new file mode 100644
index 000000000..3444069c9
--- /dev/null
+++ b/meta/packages/ubootchart/files/ubootchart-stop
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+kill -USR1 $(pidof ubootchartd_bin)
diff --git a/meta/packages/ubootchart/files/ubootchart.desktop b/meta/packages/ubootchart/files/ubootchart.desktop
new file mode 100644
index 000000000..5552b3bc6
--- /dev/null
+++ b/meta/packages/ubootchart/files/ubootchart.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=/sbin/ubootchart-stop
+Name=Stop Bootchart
+Type=Application
+Categories=Programming;
diff --git a/meta/packages/ubootchart/ubootchart_svn.bb b/meta/packages/ubootchart/ubootchart_svn.bb
new file mode 100644
index 000000000..7ab485c58
--- /dev/null
+++ b/meta/packages/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "A boot profiling tool"
+HOMEPAGE = "http://code.google.com/p/ubootchart/"
+LICENSE = "GPLv3"
+PV = "0.0+r${SRCREV}"
+PR = "r2"
+
+RRECOMMENDS = "acct"
+
+SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
+ file://sysvinit.patch;patch=1;pnum=0 \
+ file://pass-args.patch;patch=1;pnum=0 \
+ file://ubootchart-stop \
+ file://ubootchart.desktop"
+
+S = "${WORKDIR}/trunk"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "init"
+ALTERNATIVE_LINK = "${base_sbindir}/init"
+ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
+ALTERNATIVE_PRIORITY = "20"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
+}
+
+do_install() {
+ install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
+ install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
+ install -m 0755 ${S}/ubootchartd ${D}/sbin
+ install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
+ install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
+ install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+
+ install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
+ install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
+}