summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-08-28 12:59:46 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-08-28 12:59:46 +0000
commit8f041c74237fd7103e53bd78e217ec4e145207b2 (patch)
treed85ce03a6a8b90d4d1d5e4c01253a4c4ebf64514 /meta/packages
parent1039c726d869564027b97e6082a5178c6aefa627 (diff)
downloadopenembedded-core-8f041c74237fd7103e53bd78e217ec4e145207b2.tar.gz
openembedded-core-8f041c74237fd7103e53bd78e217ec4e145207b2.tar.bz2
openembedded-core-8f041c74237fd7103e53bd78e217ec4e145207b2.tar.xz
openembedded-core-8f041c74237fd7103e53bd78e217ec4e145207b2.zip
nfs-utils: start/stop also statd so clients will be able to do locking
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2578 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/nfs-utils/files/nfsserver21
-rw-r--r--meta/packages/nfs-utils/nfs-utils_1.0.6.bb2
2 files changed, 21 insertions, 2 deletions
diff --git a/meta/packages/nfs-utils/files/nfsserver b/meta/packages/nfs-utils/files/nfsserver
index bb16806ed..0e9d7be78 100644
--- a/meta/packages/nfs-utils/files/nfsserver
+++ b/meta/packages/nfs-utils/files/nfsserver
@@ -7,9 +7,10 @@
# Other control variables may be overridden here too
test -r /etc/default/nfsd && . /etc/default/nfsd
#
-# Location of exectuables:
+# Location of executables:
test -x "$NFS_MOUNTD" || NFS_MOUNTD=/usr/sbin/mountd
test -x "$NFS_NFSD" || NFS_NFSD=/usr/sbin/nfsd
+test -x "$NFS_STATD" || NFS_STATD=/usr/sbin/statd
#
# The user mode program must also exist (it just starts the kernel
# threads using the kernel module code).
@@ -104,6 +105,20 @@ stop_nfsd(){
echo failed
fi
}
+
+#statd
+start_statd(){
+ echo -n "starting statd: "
+ start-stop-daemon --start --exec "$NFS_STATD"
+ echo done
+}
+stop_statd(){
+ # WARNING: this kills any process with the executable
+ # name 'statd'.
+ echo -n 'stopping statd: '
+ start-stop-daemon --stop --quiet --signal 1 --name statd
+ echo done
+}
#----------------------------------------------------------------------
#
# supported options:
@@ -116,15 +131,19 @@ case "$1" in
start) create_directories
start_nfsd "$NFS_SERVERS"
start_mountd
+ start_statd
test -r /etc/exports && exportfs -a;;
stop) exportfs -ua
+ stop_statd
stop_mountd
stop_nfsd;;
reload) test -r /etc/exports && exportfs -r;;
restart)exportfs -ua
stop_mountd
+ stop_statd
# restart does not restart the kernel threads,
# only the user mode processes
start_mountd
+ start_statd
test -r /etc/exports && exportfs -a;;
esac
diff --git a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb b/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
index fbc2a96a3..15e391447 100644
--- a/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
+++ b/meta/packages/nfs-utils/nfs-utils_1.0.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "userspace utilities for kernel nfs"
PRIORITY = "optional"
SECTION = "console/network"
LICENSE = "GPL"
-PR = "r11"
+PR = "r12"
SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
file://acinclude-lossage.patch;patch=1 \