summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorMatthew Allum <mallum@openedhand.com>2006-08-08 08:41:31 +0000
committerMatthew Allum <mallum@openedhand.com>2006-08-08 08:41:31 +0000
commit91e99388ebfd042fffa94008cb098aad493d933a (patch)
tree859fb1ce30c06f31fbf8737eaf1e9c88c6012248 /meta/packages
parent1c6dd82bd8ea6d7d6e2107488557e5e339f223af (diff)
downloadopenembedded-core-91e99388ebfd042fffa94008cb098aad493d933a.tar.gz
openembedded-core-91e99388ebfd042fffa94008cb098aad493d933a.tar.bz2
openembedded-core-91e99388ebfd042fffa94008cb098aad493d933a.tar.xz
openembedded-core-91e99388ebfd042fffa94008cb098aad493d933a.zip
Add gconf macro file so mb builds again with gconf dep
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@594 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm/gconf-2.m439
-rw-r--r--meta/packages/matchbox-wm/matchbox-wm_1.1.bb5
2 files changed, 42 insertions, 2 deletions
diff --git a/meta/packages/matchbox-wm/matchbox-wm/gconf-2.m4 b/meta/packages/matchbox-wm/matchbox-wm/gconf-2.m4
new file mode 100644
index 000000000..aca7c7da4
--- /dev/null
+++ b/meta/packages/matchbox-wm/matchbox-wm/gconf-2.m4
@@ -0,0 +1,39 @@
+dnl AM_GCONF_SOURCE_2
+dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
+dnl (i.e. pass to gconftool-2
+dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
+dnl you should install foo.schemas files
+dnl
+
+AC_DEFUN([AM_GCONF_SOURCE_2],
+[
+ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
+ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
+ else
+ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
+ fi
+
+ AC_ARG_WITH(gconf-source,
+ [ --with-gconf-source=sourceaddress Config database for installing schema files.],GCONF_SCHEMA_CONFIG_SOURCE="$withval",)
+
+ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
+ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
+
+ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
+ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
+ fi
+
+ AC_ARG_WITH(gconf-schema-file-dir,
+ [ --with-gconf-schema-file-dir=dir Directory for installing schema files.],GCONF_SCHEMA_FILE_DIR="$withval",)
+
+ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
+ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
+
+ AC_ARG_ENABLE(schemas-install,
+ [ --disable-schemas-install Disable the schemas installation],
+ [case ${enableval} in
+ yes|no) ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-schemas-install) ;;
+ esac])
+ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
+])
diff --git a/meta/packages/matchbox-wm/matchbox-wm_1.1.bb b/meta/packages/matchbox-wm/matchbox-wm_1.1.bb
index 4af6b0a4e..05689d94e 100644
--- a/meta/packages/matchbox-wm/matchbox-wm_1.1.bb
+++ b/meta/packages/matchbox-wm/matchbox-wm_1.1.bb
@@ -3,11 +3,12 @@ DESCRIPTION = "Matchbox window manager"
LICENSE = "GPL"
DEPENDS = "libmatchbox libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat matchbox-common"
RDEPENDS = "matchbox-common"
-PR="r0"
+PR="r1"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/1.1/matchbox-window-manager-${PV}.tar.gz \
- file://kbdconfig"
+ file://kbdconfig \
+ file://gconf-2.m4"
S = "${WORKDIR}/matchbox-window-manager-${PV}"