summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-12 15:37:21 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-12 15:37:21 +0000
commita43863b7f126b4e4e9eae64c11b657ef9530e50a (patch)
treeb4fde6ff27b409c26e89ceda469ee27f3824799b /meta/packages
parent669aeb73eb48b7b224b91e5108d8d736d9489cba (diff)
downloadopenembedded-core-a43863b7f126b4e4e9eae64c11b657ef9530e50a.tar.gz
openembedded-core-a43863b7f126b4e4e9eae64c11b657ef9530e50a.tar.bz2
openembedded-core-a43863b7f126b4e4e9eae64c11b657ef9530e50a.tar.xz
openembedded-core-a43863b7f126b4e4e9eae64c11b657ef9530e50a.zip
apr: Remove workdir path references from installed apr files
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/apr/apr-util_1.3.4.bb2
-rw-r--r--meta/packages/apr/apr/configfix.patch51
-rw-r--r--meta/packages/apr/apr_1.3.3.bb5
3 files changed, 55 insertions, 3 deletions
diff --git a/meta/packages/apr/apr-util_1.3.4.bb b/meta/packages/apr/apr-util_1.3.4.bb
index 590c22e88..2c9432a15 100644
--- a/meta/packages/apr/apr-util_1.3.4.bb
+++ b/meta/packages/apr/apr-util_1.3.4.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
DEPENDS = "apr expat gdbm"
LICENSE = "Apache License, Version 2.0"
-PR = "r2"
+PR = "r3"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
file://configure_fixes.patch;patch=1"
diff --git a/meta/packages/apr/apr/configfix.patch b/meta/packages/apr/apr/configfix.patch
new file mode 100644
index 000000000..ec46172c6
--- /dev/null
+++ b/meta/packages/apr/apr/configfix.patch
@@ -0,0 +1,51 @@
+Index: apr-1.3.3/apr-config.in
+===================================================================
+--- apr-1.3.3.orig/apr-config.in 2009-01-12 15:16:31.000000000 +0000
++++ apr-1.3.3/apr-config.in 2009-01-12 15:19:25.000000000 +0000
+@@ -152,14 +152,7 @@
+ flags="$flags $LDFLAGS"
+ ;;
+ --includes)
+- if test "$location" = "installed"; then
+ flags="$flags -I$includedir $EXTRA_INCLUDES"
+- elif test "$location" = "source"; then
+- flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+- else
+- # this is for VPATH builds
+- flags="$flags -I$APR_BUILD_DIR/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+- fi
+ ;;
+ --srcdir)
+ echo $APR_SOURCE_DIR
+@@ -181,29 +167,14 @@
+ exit 0
+ ;;
+ --link-ld)
+- if test "$location" = "installed"; then
+- ### avoid using -L if libdir is a "standard" location like /usr/lib
+- flags="$flags -L$libdir -l${APR_LIBNAME}"
+- else
+- ### this surely can't work since the library is in .libs?
+- flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}"
+- fi
++ flags="$flags -l${APR_LIBNAME}"
+ ;;
+ --link-libtool)
+ # If the LA_FILE exists where we think it should be, use it. If we're
+ # installed and the LA_FILE does not exist, assume to use -L/-l
+ # (the LA_FILE may not have been installed). If we're building ourselves,
+ # we'll assume that at some point the .la file be created.
+- if test -f "$LA_FILE"; then
+- flags="$flags $LA_FILE"
+- elif test "$location" = "installed"; then
+- ### avoid using -L if libdir is a "standard" location like /usr/lib
+- # Since the user is specifying they are linking with libtool, we
+- # *know* that -R will be recognized by libtool.
+- flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}"
+- else
+- flags="$flags $LA_FILE"
+- fi
++ flags="$flags ll${APR_LIBNAME}"
+ ;;
+ --shlib-path-var)
+ echo "$SHLIBPATH_VAR"
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb
index 3e23bcd87..ac25246be 100644
--- a/meta/packages/apr/apr_1.3.3.bb
+++ b/meta/packages/apr/apr_1.3.3.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
SECTION = "libs"
LICENSE = "Apache License, Version 2.0"
-PR = "r0"
+PR = "r2"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
- file://configure_fixes.patch;patch=1"
+ file://configure_fixes.patch;patch=1 \
+ file://configfix.patch;patch=1"
inherit autotools lib_package binconfig