summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRobert Bragg <bob@openedhand.com>2008-09-26 15:16:32 +0000
committerRobert Bragg <bob@openedhand.com>2008-09-26 15:16:32 +0000
commitc4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc (patch)
tree435045091d55f4f2dd32d8384b69827dc8db09e8 /meta/packages
parent52734d2374d3ac4eaee206537a7708fefb46c4cc (diff)
downloadopenembedded-core-c4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc.tar.gz
openembedded-core-c4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc.tar.bz2
openembedded-core-c4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc.tar.xz
openembedded-core-c4e9ad655ca02e39f57b8ccb7bf5f34b1feeb3bc.zip
Fixes the metacity-clutter revision; packages the plugins; and adds a post
install section to use gconftool-2 to enable the "simple" plugin by default. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5299 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/gnome/metacity-clutter_git.bb18
1 files changed, 15 insertions, 3 deletions
diff --git a/meta/packages/gnome/metacity-clutter_git.bb b/meta/packages/gnome/metacity-clutter_git.bb
index d32927147..831ba507e 100644
--- a/meta/packages/gnome/metacity-clutter_git.bb
+++ b/meta/packages/gnome/metacity-clutter_git.bb
@@ -2,8 +2,8 @@ SECTION = "x11/wm"
DESCRIPTION = "Metacity is the boring window manager for the adult in you."
LICENSE = "GPL"
DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native"
-PR = "r0"
-PV = "2.25.1+gitr${SRCREV}"
+PR = "r2"
+PV = "2.25.1+git${SRCREV}"
inherit gnome update-alternatives
SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter"
@@ -18,9 +18,21 @@ EXTRA_OECONF += "--disable-verbose \
--disable-xinerama \
--with-clutter"
-FILES_${PN} += "${datadir}/themes"
+FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so"
+FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
do_stage () {
autotools_stage_all
}
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[simple]'
+}
+