summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-06-21 03:46:34 -0700
committerSaul Wold <Saul.Wold@intel.com>2010-07-08 22:05:20 -0700
commitd42466ea43827f1c6a5a972819dac273e381d33d (patch)
tree72c6a9d981257dc2c3fd2173bc56657b20c1061e /meta/packages
parentf516cfcac0b2d56aebe1da2a00301c669ca77ab9 (diff)
downloadopenembedded-core-d42466ea43827f1c6a5a972819dac273e381d33d.tar.gz
openembedded-core-d42466ea43827f1c6a5a972819dac273e381d33d.tar.bz2
openembedded-core-d42466ea43827f1c6a5a972819dac273e381d33d.tar.xz
openembedded-core-d42466ea43827f1c6a5a972819dac273e381d33d.zip
libtool family: upgrade from 2.2.6 to 2.2.10
This upgrades these recipes: libtool_2.2.6.bb -> libtool_2.2.10.bb libtool-native_2.2.6.bb -> libtool-native_2.2.10.bb libtool-cross_2.2.6.bb -> libtool-cross_2.2.10.bb libtool-nativesdk_2.2.6.bb -> libtool-nativesdk_2.2.10.bb Also fixes build failure caused by having aclocal.m4 built with older version of libtool. Rebased these patches for the newer version sources add_dolt.patch cross_compile.patch dolt.m4 Changed this patch to fix documentation building for non-x86 archs prefix.patch Rebased and changed to fix the building of ncurses recipe: trailingslash.patch Also updated metadata variables like LICENSE & LIC_CHKSUM_FILES Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/libtool/libtool-cross_2.2.10.bb (renamed from meta/packages/libtool/libtool-cross_2.2.6.bb)9
-rw-r--r--meta/packages/libtool/libtool-native_2.2.10.bb (renamed from meta/packages/libtool/libtool-native_2.2.6.bb)7
-rw-r--r--meta/packages/libtool/libtool-nativesdk_2.2.10.bb (renamed from meta/packages/libtool/libtool-nativesdk_2.2.6.bb)11
-rw-r--r--meta/packages/libtool/libtool.inc11
-rw-r--r--meta/packages/libtool/libtool/add_dolt.patch (renamed from meta/packages/libtool/libtool-2.2.6/add_dolt.patch)0
-rw-r--r--meta/packages/libtool/libtool/cross_compile.patch (renamed from meta/packages/libtool/libtool-2.2.6/cross_compile.patch)12
-rw-r--r--meta/packages/libtool/libtool/dolt.m4 (renamed from meta/packages/libtool/libtool-2.2.6/dolt.m4)0
-rw-r--r--meta/packages/libtool/libtool/prefix.patch (renamed from meta/packages/libtool/libtool-2.2.6/prefix.patch)60
-rw-r--r--meta/packages/libtool/libtool/trailingslash.patch (renamed from meta/packages/libtool/libtool-2.2.6/trailingslash.patch)16
-rw-r--r--meta/packages/libtool/libtool_2.2.10.bb (renamed from meta/packages/libtool/libtool_2.2.6.bb)7
10 files changed, 82 insertions, 51 deletions
diff --git a/meta/packages/libtool/libtool-cross_2.2.6.bb b/meta/packages/libtool/libtool-cross_2.2.10.bb
index f08182461..08b27f47b 100644
--- a/meta/packages/libtool/libtool-cross_2.2.6.bb
+++ b/meta/packages/libtool/libtool-cross_2.2.10.bb
@@ -1,15 +1,14 @@
require libtool_${PV}.bb
-PR = "r31"
+PR = "r0"
PACKAGES = ""
-SRC_URI_append = " file://cross_compile.patch;patch=1 \
- file://prefix.patch;patch=1"
+SRC_URI_append = " file://cross_compile.patch "
DEPENDS += "libtool-native"
DOLT_PATCH = ""
-DOLT_PATCH_arm = " file://add_dolt.patch;patch=1"
-DOLT_PATCH_i586 = " file://add_dolt.patch;patch=1"
+DOLT_PATCH_arm = " file://add_dolt.patch"
+DOLT_PATCH_i586 = " file://add_dolt.patch"
#SRC_URI_append_linux = "${DOLT_PATCH}"
#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
diff --git a/meta/packages/libtool/libtool-native_2.2.6.bb b/meta/packages/libtool/libtool-native_2.2.10.bb
index c5827ffb4..5af5d7b94 100644
--- a/meta/packages/libtool/libtool-native_2.2.6.bb
+++ b/meta/packages/libtool/libtool-native_2.2.10.bb
@@ -1,8 +1,9 @@
require libtool_${PV}.bb
-PR = "r23"
-SRC_URI_append = " file://cross_compile.patch;patch=1 \
- file://prefix.patch;patch=1"
+DEPENDS = ""
+
+PR = "r0"
+SRC_URI_append = " file://cross_compile.patch "
inherit native
diff --git a/meta/packages/libtool/libtool-nativesdk_2.2.6.bb b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
index 77acbd585..05444c7cc 100644
--- a/meta/packages/libtool/libtool-nativesdk_2.2.6.bb
+++ b/meta/packages/libtool/libtool-nativesdk_2.2.10.bb
@@ -1,10 +1,17 @@
require libtool_${PV}.bb
-PR = "r4"
-SRC_URI_append = " file://cross_compile.patch;patch=1"
+PR = "r0"
+SRC_URI_append = " file://cross_compile.patch"
inherit nativesdk
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
do_install () {
autotools_do_install
install -d ${D}${bindir}/
diff --git a/meta/packages/libtool/libtool.inc b/meta/packages/libtool/libtool.inc
index db86d15ba..81c3eaf6d 100644
--- a/meta/packages/libtool/libtool.inc
+++ b/meta/packages/libtool/libtool.inc
@@ -3,6 +3,15 @@ This is GNU libtool, a generic library support script. Libtool hides \
the complexity of generating special library types (such as shared \
libraries) behind a consistent interface."
HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
-LICENSE = "GPL"
SECTION = "devel"
+LICENSE = "GPLv2, LGPLv2.1"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+ file://libltdl/COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06 \
+ "
+
+SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
+ file://trailingslash.patch \
+ file://prefix.patch \
+ file://dolt.m4 "
diff --git a/meta/packages/libtool/libtool-2.2.6/add_dolt.patch b/meta/packages/libtool/libtool/add_dolt.patch
index 2c5df9603..2c5df9603 100644
--- a/meta/packages/libtool/libtool-2.2.6/add_dolt.patch
+++ b/meta/packages/libtool/libtool/add_dolt.patch
diff --git a/meta/packages/libtool/libtool-2.2.6/cross_compile.patch b/meta/packages/libtool/libtool/cross_compile.patch
index b4bacbd12..fc1f4b6fb 100644
--- a/meta/packages/libtool/libtool-2.2.6/cross_compile.patch
+++ b/meta/packages/libtool/libtool/cross_compile.patch
@@ -4,11 +4,11 @@ Not upstreable in this form.
RP - 01/05/2008
-Index: libtool-2.2.2/libltdl/config/ltmain.m4sh
+Index: libtool-2.2.10/libltdl/config/ltmain.m4sh
===================================================================
---- libtool-2.2.2.orig/libltdl/config/ltmain.m4sh 2008-05-01 21:48:42.000000000 +0100
-+++ libtool-2.2.2/libltdl/config/ltmain.m4sh 2008-05-01 21:51:41.000000000 +0100
-@@ -4454,8 +4454,14 @@
+--- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh
++++ libtool-2.2.10/libltdl/config/ltmain.m4sh
+@@ -5147,8 +5147,14 @@ func_mode_link ()
absdir="$abs_ladir"
libdir="$abs_ladir"
else
@@ -25,7 +25,7 @@ Index: libtool-2.2.2/libltdl/config/ltmain.m4sh
fi
test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
else
-@@ -4825,8 +4831,6 @@
+@@ -5519,8 +5525,6 @@ func_mode_link ()
add="$libdir/$linklib"
fi
else
@@ -34,7 +34,7 @@ Index: libtool-2.2.2/libltdl/config/ltmain.m4sh
# Try looking first in the location we're being installed to.
if test -n "$inst_prefix_dir"; then
case $libdir in
-@@ -4972,7 +4976,17 @@
+@@ -5667,7 +5671,17 @@ func_mode_link ()
fi
;;
*)
diff --git a/meta/packages/libtool/libtool-2.2.6/dolt.m4 b/meta/packages/libtool/libtool/dolt.m4
index 9bedecf27..9bedecf27 100644
--- a/meta/packages/libtool/libtool-2.2.6/dolt.m4
+++ b/meta/packages/libtool/libtool/dolt.m4
diff --git a/meta/packages/libtool/libtool-2.2.6/prefix.patch b/meta/packages/libtool/libtool/prefix.patch
index 639feb745..895be1f9b 100644
--- a/meta/packages/libtool/libtool-2.2.6/prefix.patch
+++ b/meta/packages/libtool/libtool/prefix.patch
@@ -1,22 +1,31 @@
Renames "libtool" -> "${TARGET_PREFIX}libtool" which makes sure
it can't be confused with the host libtool.
-Index: libtool-2.2.2/libltdl/m4/libtool.m4
+
+After discussions with RP Changed host_alias to build_alias
+at one place as it was causing man page building issue while
+cross compiling for different architectures.
+
+Date: 2010/06/28
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+
+
+Index: libtool-2.2.10/libltdl/m4/libtool.m4
===================================================================
---- libtool-2.2.2.orig/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100
-+++ libtool-2.2.2/libltdl/m4/libtool.m4 2008-04-13 22:43:05.000000000 +0100
-@@ -89,7 +89,8 @@
+--- libtool-2.2.10.orig/libltdl/m4/libtool.m4
++++ libtool-2.2.10/libltdl/m4/libtool.m4
+@@ -94,7 +94,8 @@ _LT_SET_OPTIONS([$0], [$1])
LIBTOOL_DEPS="$ltmain"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+LIBTOOL='$(SHELL) $(top_builddir)'
-+LIBTOOL="$LIBTOOL/$host_alias-libtool"
++LIBTOOL="$LIBTOOL/${host_alias}-libtool"
AC_SUBST(LIBTOOL)dnl
_LT_SETUP
-@@ -211,7 +212,7 @@
- no_glob_subst='s/\*/\\\*/g'
+@@ -201,7 +202,7 @@ aix3*)
+ esac
# Global variables:
-ofile=libtool
@@ -24,20 +33,20 @@ Index: libtool-2.2.2/libltdl/m4/libtool.m4
can_build_shared=yes
# All known linkers require a `.a' archive for static linking (except MSVC,
-Index: libtool-2.2.2/Makefile.am
+Index: libtool-2.2.10/Makefile.am
===================================================================
---- libtool-2.2.2.orig/Makefile.am 2008-04-01 19:06:08.000000000 +0100
-+++ libtool-2.2.2/Makefile.am 2008-04-13 22:49:17.000000000 +0100
-@@ -31,7 +31,7 @@
+--- libtool-2.2.10.orig/Makefile.am
++++ libtool-2.2.10/Makefile.am
+@@ -31,7 +31,7 @@ AM_LDFLAGS =
DIST_SUBDIRS = .
EXTRA_DIST =
--BUILT_SOURCES = libtool
-+BUILT_SOURCES = $(host_alias)-libtool
+-BUILT_SOURCES = libtool libtoolize
++BUILT_SOURCES = $(host_alias)-libtool libtoolize
CLEANFILES =
MOSTLYCLEANFILES =
-@@ -64,7 +64,7 @@
+@@ -65,7 +65,7 @@ rebuild = rebuild=:; $(timestamp); corre
## ---------------- ##
# The libtool distributor and the standalone libtool script.
@@ -46,7 +55,7 @@ Index: libtool-2.2.2/Makefile.am
libtoolize: $(srcdir)/libtoolize.in $(top_builddir)/config.status
rm -f libtoolize.tmp libtoolize
-@@ -90,8 +90,8 @@
+@@ -91,8 +91,8 @@ $(srcdir)/libtoolize.in: $(sh_files) lib
# We used to do this with a 'stamp-vcl' file, but non-gmake builds
# would rerun configure on every invocation, so now we manually
# check the version numbers from the build rule when necessary.
@@ -57,7 +66,7 @@ Index: libtool-2.2.2/Makefile.am
if test -f "$$target"; then \
set dummy `./$$target --version | sed 1q`; actualver="$$5"; \
test "$$actualver" = "$$correctver" && rebuild=false; \
-@@ -100,8 +100,8 @@
+@@ -101,8 +101,8 @@ libtool: $(top_builddir)/config.status $
case $$prereq in *ChangeLog);; *) rebuild=:;; esac; \
done; \
if $$rebuild; then \
@@ -68,16 +77,25 @@ Index: libtool-2.2.2/Makefile.am
fi
.PHONY: configure-subdirs
-@@ -145,7 +145,7 @@
- ChangeLog.1999 ChangeLog.2000 ChangeLog.2001 \
+@@ -147,7 +147,7 @@ EXTRA_DIST += bootstrap $(srcdir)/li
ChangeLog.2002 ChangeLog.2003 ChangeLog.2004 \
- ChangeLog.2005 ChangeLog.2006 ChangeLog.2007
+ ChangeLog.2005 ChangeLog.2006 ChangeLog.2007 \
+ ChangeLog.2008 ChangeLog.2009
-CLEANFILES += libtool libtoolize libtoolize.tmp \
+CLEANFILES += $(host_alias)-libtool libtoolize libtoolize.tmp \
$(auxdir)/ltmain.tmp $(m4dir)/ltversion.tmp
## We build ltversion.m4 here, instead of from config.status,
-@@ -483,12 +483,12 @@
+@@ -337,7 +337,7 @@ update_mans = \
+ PATH=.$(PATH_SEPARATOR)$$PATH; export PATH; \
+ $(HELP2MAN) --output=$@
+ $(srcdir)/doc/libtool.1: $(srcdir)/$(auxdir)/ltmain.sh
+- $(update_mans) --help-option=--help-all libtool
++ $(update_mans) --help-option=--help-all ${build_alias}-libtool
+ $(srcdir)/doc/libtoolize.1: $(srcdir)/libtoolize.in
+ $(update_mans) libtoolize
+
+@@ -523,12 +523,12 @@ TESTS_ENVIRONMENT = MAKE="$(MAKE)" CC="$
BUILDCHECK_ENVIRONMENT = _lt_pkgdatadir="$(abs_top_srcdir)" \
LIBTOOLIZE="$(abs_top_builddir)/libtoolize" \
@@ -92,7 +110,7 @@ Index: libtool-2.2.2/Makefile.am
LTDLINCL="-I$(includedir)" \
LIBLTDL="$(libdir)/libltdl.la" \
tst_aclocaldir="$(aclocaldir)"
-@@ -620,7 +620,7 @@
+@@ -679,7 +679,7 @@ if HAVE_FC
TESTS += $(FC_TESTS)
endif
diff --git a/meta/packages/libtool/libtool-2.2.6/trailingslash.patch b/meta/packages/libtool/libtool/trailingslash.patch
index b1956a613..f51c06406 100644
--- a/meta/packages/libtool/libtool-2.2.6/trailingslash.patch
+++ b/meta/packages/libtool/libtool/trailingslash.patch
@@ -4,20 +4,20 @@ This is because libdir has a trailing slash which breaks the comparision.
RP 2/1/10
-Index: libtool-2.2.6/libltdl/config/ltmain.m4sh
+Index: libtool-2.2.10/libltdl/config/ltmain.m4sh
===================================================================
---- libtool-2.2.6.orig/libltdl/config/ltmain.m4sh 2010-02-02 16:06:29.793905001 +0000
-+++ libtool-2.2.6/libltdl/config/ltmain.m4sh 2010-02-02 16:06:59.415155959 +0000
-@@ -1567,8 +1567,12 @@
+--- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh
++++ libtool-2.2.10/libltdl/config/ltmain.m4sh
+@@ -1634,8 +1634,12 @@ func_mode_install ()
dir="$dir$objdir"
if test -n "$relink_command"; then
-+ # Strip any trailing slash from the destination.
-+ func_stripname '' '/' "$libdir"
-+ destlibdir=$func_stripname_result
++ # Strip any trailing slash from the destination.
++ func_stripname '' '/' "$libdir"
++ destlibdir=$func_stripname_result
+
# Determine the prefix the user has applied to our future dir.
-- inst_prefix_dir=`$ECHO "X$destdir" | $Xsed -e "s%$libdir\$%%"`
+- inst_prefix_dir=`$ECHO "$destdir" | $SED -e "s%$libdir\$%%"`
+ inst_prefix_dir=`$ECHO "X$destdir" | $Xsed -e "s%$destlibdir\$%%"`
# Don't allow the user to place us outside of our expected
diff --git a/meta/packages/libtool/libtool_2.2.6.bb b/meta/packages/libtool/libtool_2.2.10.bb
index e5deac7c4..cca3b1ea4 100644
--- a/meta/packages/libtool/libtool_2.2.6.bb
+++ b/meta/packages/libtool/libtool_2.2.10.bb
@@ -1,10 +1,7 @@
require libtool.inc
+DEPENDS = "libtool-native"
-PR = "r21"
-
-SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}a.tar.gz \
- file://trailingslash.patch;patch=1 \
- file://dolt.m4"
+PR = "r0"
PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
FILES_${PN} += "${datadir}/aclocal*"