summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:01:07 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:01:07 +0100
commite6d96312f5d8d78de3874233b6fa9a891d1a5a76 (patch)
tree35d054e021a9b2924e529661ac4d8f4bbcafff59 /meta/packages
parent59bb17f5c492e2f3e32df8e1a29b4cb8fddb4b05 (diff)
downloadopenembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.gz
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.bz2
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.tar.xz
openembedded-core-e6d96312f5d8d78de3874233b6fa9a891d1a5a76.zip
mozilla-headless: Convert to hg and add mozilla-headless-services
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch13
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless-services_git.bb12
-rw-r--r--meta/packages/mozilla-headless/mozilla-headless_hg.bb (renamed from meta/packages/mozilla-headless/mozilla-headless_git.bb)6
3 files changed, 28 insertions, 3 deletions
diff --git a/meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch b/meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch
new file mode 100644
index 000000000..dcfe11e0f
--- /dev/null
+++ b/meta/packages/mozilla-headless/mozilla-headless-services/confighack.patch
@@ -0,0 +1,13 @@
+Index: places-glib/configure.ac
+===================================================================
+--- places-glib.orig/configure.ac 2009-04-17 10:29:15.000000000 +0100
++++ places-glib/configure.ac 2009-04-17 10:29:44.000000000 +0100
+@@ -99,6 +99,8 @@
+ PKG_CHECK_MODULES(GLIB, [glib-2.0])
+ PKG_CHECK_MODULES(DBUS, [dbus-glib-1])
+
++XUL_LIBS="$XUL_LIBS -lmozjs"
++
+ MOZHOME=`${PKG_CONFIG} --variable=prefix mozilla-headless`"/lib/xulrunner-"`${PKG_CONFIG} --modversion mozilla-headless`
+ AC_SUBST([MOZHOME])
+
diff --git a/meta/packages/mozilla-headless/mozilla-headless-services_git.bb b/meta/packages/mozilla-headless/mozilla-headless-services_git.bb
new file mode 100644
index 000000000..cb538ee3f
--- /dev/null
+++ b/meta/packages/mozilla-headless/mozilla-headless-services_git.bb
@@ -0,0 +1,12 @@
+SRC_URI = "git://git.moblin.org/mozilla-headless-services.git;protocol=git \
+ file://confighack.patch;patch=1"
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+DEPENDS = "glib-2.0 dbus mozilla-headless"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/dbus-1/services"
+
+inherit autotools_stage
diff --git a/meta/packages/mozilla-headless/mozilla-headless_git.bb b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
index 7e59ed35f..e3ef60b78 100644
--- a/meta/packages/mozilla-headless/mozilla-headless_git.bb
+++ b/meta/packages/mozilla-headless/mozilla-headless_hg.bb
@@ -1,9 +1,9 @@
-SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=c6fe23d41598;module=offscreen \
+SRC_URI = "hg://hg.mozilla.org/incubator;protocol=http;rev=71b4ab01cbf2;module=offscreen \
file://configurefix.patch;patch=1 \
file://jsautocfg.h \
file://mozconfig"
-PV = "0.0+hg-1.0+c6fe23d41598"
+PV = "0.0+hg-1.0+71b4ab01cbf2"
PR = "r0"
S = "${WORKDIR}/offscreen"
@@ -34,7 +34,7 @@ do_compile () {
base_do_compile
}
-EXTRA_OECONF =+ "--enable-application=xulrunner --disable-javaxpcom --enable-system-sqlite --enable-default-toolkit=cairo-headless --disable-printing --disable-crashreporter --disable-plugins --disable-accessibility --enable-pango --disable-tests"
+EXTRA_OECONF =+ "--enable-application=xulrunner --enable-default-toolkit=cairo-headless --enable-pango --disable-optimize --enable-debug --disable-tests --disable-printing --disable-crashreporter --disable-accessibility --disable-javaxpcom --enable-plugins --enable-system-sqlite --disable-necko-wifi"
export LIBXUL_DIST="${S}/dist"