summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-05 15:57:59 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-05 15:57:59 +0000
commite93ccce41330d44721b4f87a74b304a6d6d72482 (patch)
tree38fdbf4e28fc6413ede43f14ce3877530e698e1c /meta/packages
parent96cdddcdd707517d111330b9471ef88087d0d0ab (diff)
downloadopenembedded-core-e93ccce41330d44721b4f87a74b304a6d6d72482.tar.gz
openembedded-core-e93ccce41330d44721b4f87a74b304a6d6d72482.tar.bz2
openembedded-core-e93ccce41330d44721b4f87a74b304a6d6d72482.tar.xz
openembedded-core-e93ccce41330d44721b4f87a74b304a6d6d72482.zip
eds-dbus: Pull from git, not svn
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/eds/eds-dbus/no_iconv_test.patch30
-rw-r--r--meta/packages/eds/eds-dbus/nossl.patch68
-rw-r--r--meta/packages/eds/eds-dbus/oh-contact.patch14
-rw-r--r--meta/packages/eds/eds-dbus_git.bb (renamed from meta/packages/eds/eds-dbus_svn.bb)19
4 files changed, 87 insertions, 44 deletions
diff --git a/meta/packages/eds/eds-dbus/no_iconv_test.patch b/meta/packages/eds/eds-dbus/no_iconv_test.patch
deleted file mode 100644
index 4a034b6c5..000000000
--- a/meta/packages/eds/eds-dbus/no_iconv_test.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: trunk/configure.in
-===================================================================
---- trunk.orig/configure.in 2005-09-28 17:34:08.000000000 +0000
-+++ trunk/configure.in 2005-09-28 19:13:22.000000000 +0000
-@@ -254,25 +221,6 @@
- AC_SUBST(ICONV_CFLAGS)
- AC_SUBST(ICONV_LIBS)
-
--CFLAGS="$CFLAGS -I$srcdir"
--
--AC_MSG_CHECKING(preferred charset formats for system iconv)
--AC_TRY_RUN([
--#define CONFIGURE_IN
--#include "iconv-detect.c"
--],[
-- AC_MSG_RESULT(found)
--],[
-- AC_MSG_RESULT(not found)
-- AC_WARN([
-- *** The iconv-detect program was unable to determine the
-- *** preferred charset formats recognized by your system
-- *** iconv library. It is suggested that you install a
-- *** working iconv library such as the one found at
-- *** ftp://ftp.gnu.org/pub/gnu/libiconv
-- ])
--])
--
- CFLAGS="$save_CFLAGS"
- LIBS="$save_LIBS"
-
diff --git a/meta/packages/eds/eds-dbus/nossl.patch b/meta/packages/eds/eds-dbus/nossl.patch
new file mode 100644
index 000000000..30568ff07
--- /dev/null
+++ b/meta/packages/eds/eds-dbus/nossl.patch
@@ -0,0 +1,68 @@
+Index: git/camel/Makefile.am
+===================================================================
+--- git.orig/camel/Makefile.am 2010-02-05 15:25:09.000000000 +0000
++++ git/camel/Makefile.am 2010-02-05 15:25:20.000000000 +0000
+@@ -80,7 +80,6 @@
+ camel-store-summary.c \
+ camel-store.c \
+ camel-tcp-stream-raw.c \
+- camel-tcp-stream-ssl.c \
+ camel-tcp-stream.c \
+ camel-transport.c \
+ camel-uid-cache.c \
+@@ -133,7 +132,6 @@
+ camel-store-summary.h \
+ camel-store.h \
+ camel-tcp-stream-raw.h \
+- camel-tcp-stream-ssl.h \
+ camel-tcp-stream.h \
+ camel-transport.h \
+ camel-uid-cache.h \
+Index: git/camel/camel.h
+===================================================================
+--- git.orig/camel/camel.h 2010-02-05 15:26:30.000000000 +0000
++++ git/camel/camel.h 2010-02-05 15:26:52.000000000 +0000
+@@ -122,7 +122,6 @@
+ #include <camel/camel-string-utils.h>
+ #include <camel/camel-tcp-stream.h>
+ #include <camel/camel-tcp-stream-raw.h>
+-#include <camel/camel-tcp-stream-ssl.h>
+ #include <camel/camel-text-index.h>
+ #include <camel/camel-transport.h>
+ #include <camel/camel-trie.h>
+Index: git/camel/providers/imap/camel-imap-store.c
+===================================================================
+--- git.orig/camel/providers/imap/camel-imap-store.c 2010-02-05 15:28:19.000000000 +0000
++++ git/camel/providers/imap/camel-imap-store.c 2010-02-05 15:28:38.000000000 +0000
+@@ -51,7 +51,6 @@
+ #include "camel/camel-stream.h"
+ #include "camel/camel-string-utils.h"
+ #include "camel/camel-tcp-stream-raw.h"
+-#include "camel/camel-tcp-stream-ssl.h"
+ #include "camel/camel-url.h"
+ #include "camel/camel-utf8.h"
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2010-02-05 15:31:59.000000000 +0000
++++ git/configure.ac 2010-02-05 15:33:00.000000000 +0000
+@@ -1272,7 +1272,8 @@
+ dnl We have fixed all our instances to use <libical/ical.h>. Until the .pc from
+ dnl libical is fixed, we have to work-around the buggy CFlags.
+ dnl *****
+- LIBICAL_EXTRA_CFLAGS=" -I`$PKG_CONFIG --variable=includedir libical` "
++ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
++ LIBICAL_EXTRA_CFLAGS=" -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=includedir libical` "
+ LIBICAL_EXTRA_LIBS=""
+ AC_SUBST(LIBICAL_EXTRA_CFLAGS)
+ AC_SUBST(LIBICAL_EXTRA_LIBS)
+Index: git/calendar/libecal/libecal.pc.in
+===================================================================
+--- git.orig/calendar/libecal/libecal.pc.in 2010-02-05 15:39:41.000000000 +0000
++++ git/calendar/libecal/libecal.pc.in 2010-02-05 15:39:55.000000000 +0000
+@@ -12,4 +12,4 @@
+ Version: @VERSION@
+ Requires: libical >= @LIBICAL_REQUIRED@ libedataserver-1.2 dbus-glib-1
+ Libs: -L${libdir} -lecal-1.2
+-Cflags: -I${privincludedir} @LIBICAL_EXTRA_CFLAGS@
++Cflags: -I${privincludedir}
diff --git a/meta/packages/eds/eds-dbus/oh-contact.patch b/meta/packages/eds/eds-dbus/oh-contact.patch
index e5c0f5184..fdd7e4bdf 100644
--- a/meta/packages/eds/eds-dbus/oh-contact.patch
+++ b/meta/packages/eds/eds-dbus/oh-contact.patch
@@ -1,7 +1,7 @@
Index: addressbook/libedata-book/ximian-vcard.h
===================================================================
---- addressbook/libedata-book/ximian-vcard.h (revision 578)
-+++ addressbook/libedata-book/ximian-vcard.h (working copy)
+--- addressbook/libedata-book/ximian-vcard.h.orig 2010-02-05 14:57:14.000000000 +0000
++++ addressbook/libedata-book/ximian-vcard.h 2010-02-05 14:58:14.000000000 +0000
@@ -1,80 +1,40 @@
#define XIMIAN_VCARD \
"BEGIN:VCARD\n" \
@@ -122,10 +122,12 @@ Index: addressbook/libedata-book/ximian-vcard.h
"END:VCARD"
Index: addressbook/backends/file/Makefile.am
===================================================================
---- addressbook/backends/file/Makefile.am (revision 578)
-+++ addressbook/backends/file/Makefile.am (working copy)
-@@ -1,4 +1,5 @@
- INCLUDES = \
+--- addressbook/backends/file/Makefile.am.orig 2010-02-05 14:57:14.000000000 +0000
++++ addressbook/backends/file/Makefile.am 2010-02-05 14:59:10.000000000 +0000
+@@ -2,6 +2,7 @@
+
+ libebookbackendfile_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -DCREATE_DEFAULT_VCARD \
-DG_LOG_DOMAIN=\"libebookbackend\" \
-I$(top_srcdir) \
diff --git a/meta/packages/eds/eds-dbus_svn.bb b/meta/packages/eds/eds-dbus_git.bb
index a4c91412c..cb49630a3 100644
--- a/meta/packages/eds/eds-dbus_svn.bb
+++ b/meta/packages/eds/eds-dbus_git.bb
@@ -1,30 +1,33 @@
DESCRIPTION = "Evolution database backend server"
-HOMEPAGE = "http://projects.o-hand.com/eds"
LICENSE = "LGPL"
-DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib libsoup libglade"
+DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib libsoup libglade libical"
-PV = "1.4.0+svnr${SRCREV}"
-PR = "r6"
+PV = "2.29+git${SRCPV}"
+PR = "r2"
-SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
file://oh-contact.patch;patch=1;pnum=0 \
- file://no_iconv_test.patch;patch=1 \
+ file://nossl.patch;patch=1 \
file://iconv-detect.h"
-S = "${WORKDIR}/trunk"
+S = "${WORKDIR}/git"
inherit autotools_stage pkgconfig
# -ldb needs this on some platforms
LDFLAGS += "-lpthread"
+do_configure_prepend () {
+ echo "EXTRA_DIST = " > ${S}/gtk-doc.make
+}
+
do_configure_append () {
cp ${WORKDIR}/iconv-detect.h ${S}
}
EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
--with-soup --with-libdb=${STAGING_DIR_HOST}${prefix} \
- --disable-smime --disable-nss --disable-nntp --disable-gtk-doc"
+ --disable-smime --disable-ssl --disable-nntp --disable-gtk-doc --without-weather"
PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \