summaryrefslogtreecommitdiff
path: root/meta/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-10-11 21:40:26 +0000
committerRichard Purdie <richard@openedhand.com>2007-10-11 21:40:26 +0000
commitfeb7067476a59ceebe3a30ca35dee2e793a13aa9 (patch)
treeebeb042f65f9a42c6444f2a968326cb6041c19aa /meta/packages
parent8eec39221db38df319874d2b55532dff217c4b1c (diff)
downloadopenembedded-core-feb7067476a59ceebe3a30ca35dee2e793a13aa9.tar.gz
openembedded-core-feb7067476a59ceebe3a30ca35dee2e793a13aa9.tar.bz2
openembedded-core-feb7067476a59ceebe3a30ca35dee2e793a13aa9.tar.xz
openembedded-core-feb7067476a59ceebe3a30ca35dee2e793a13aa9.zip
syslinux, nasm: Move from meta-extras to meta
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2864 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages')
-rw-r--r--meta/packages/nasm/nasm-native_0.98.38.bb4
-rw-r--r--meta/packages/nasm/nasm_0.98.38.bb15
-rw-r--r--meta/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch10
-rw-r--r--meta/packages/syslinux/syslinux-native_2.11.bb10
-rw-r--r--meta/packages/syslinux/syslinux-native_3.11.bb5
-rw-r--r--meta/packages/syslinux/syslinux-native_3.31.bb3
-rw-r--r--meta/packages/syslinux/syslinux-native_3.36.bb3
-rw-r--r--meta/packages/syslinux/syslinux.inc29
-rw-r--r--meta/packages/syslinux/syslinux3.inc21
9 files changed, 100 insertions, 0 deletions
diff --git a/meta/packages/nasm/nasm-native_0.98.38.bb b/meta/packages/nasm/nasm-native_0.98.38.bb
new file mode 100644
index 000000000..2b3672ca8
--- /dev/null
+++ b/meta/packages/nasm/nasm-native_0.98.38.bb
@@ -0,0 +1,4 @@
+SECTION = "unknown"
+require nasm_${PV}.bb
+S = "${WORKDIR}/nasm-${PV}"
+inherit native
diff --git a/meta/packages/nasm/nasm_0.98.38.bb b/meta/packages/nasm/nasm_0.98.38.bb
new file mode 100644
index 000000000..86e7f2b93
--- /dev/null
+++ b/meta/packages/nasm/nasm_0.98.38.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "General-purpose x86 assembler"
+SECTION = "devel"
+LICENSE = "GPL"
+COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nasm/nasm-${PV}.tar.bz2"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+
+ oe_runmake 'INSTALLROOT=${D}' install
+}
diff --git a/meta/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch b/meta/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch
new file mode 100644
index 000000000..724346422
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-native-2.11/edx_assume_zero.patch
@@ -0,0 +1,10 @@
+--- syslinux-2.11/ldlinux.asm.orig 2005-11-01 14:25:10.767581544 -0700
++++ syslinux-2.11/ldlinux.asm 2005-11-01 14:25:42.175806768 -0700
+@@ -724,7 +724,6 @@
+
+ mov eax,[bsHidden] ; Hidden sectors
+ add edx,[bxResSectors]
+- add eax,edx
+ mov ecx,[bxFATsecs] ; Sectors/FAT
+ fat_load_loop:
+ mov ebp,ecx ; Make sure high EBP = 0
diff --git a/meta/packages/syslinux/syslinux-native_2.11.bb b/meta/packages/syslinux/syslinux-native_2.11.bb
new file mode 100644
index 000000000..a05728f0a
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-native_2.11.bb
@@ -0,0 +1,10 @@
+PR="r1"
+
+SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2 \
+ file://edx_assume_zero.patch;patch=1"
+
+require syslinux.inc
+
+do_compile() {
+ oe_runmake syslinux
+}
diff --git a/meta/packages/syslinux/syslinux-native_3.11.bb b/meta/packages/syslinux/syslinux-native_3.11.bb
new file mode 100644
index 000000000..28d750aab
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-native_3.11.bb
@@ -0,0 +1,5 @@
+PR="r1"
+
+SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/Old/syslinux-${PV}.tar.bz2 "
+
+require syslinux3.inc
diff --git a/meta/packages/syslinux/syslinux-native_3.31.bb b/meta/packages/syslinux/syslinux-native_3.31.bb
new file mode 100644
index 000000000..6971874ea
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-native_3.31.bb
@@ -0,0 +1,3 @@
+SRC_URI="${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+
+require syslinux3.inc
diff --git a/meta/packages/syslinux/syslinux-native_3.36.bb b/meta/packages/syslinux/syslinux-native_3.36.bb
new file mode 100644
index 000000000..d9019a4ab
--- /dev/null
+++ b/meta/packages/syslinux/syslinux-native_3.36.bb
@@ -0,0 +1,3 @@
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+
+require syslinux3.inc
diff --git a/meta/packages/syslinux/syslinux.inc b/meta/packages/syslinux/syslinux.inc
new file mode 100644
index 000000000..41be168d1
--- /dev/null
+++ b/meta/packages/syslinux/syslinux.inc
@@ -0,0 +1,29 @@
+# syslinux-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A multi-purpose linux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+LICENSE="GPL"
+
+# If you really want to run syslinux, you need mtools. We just want the
+# ldlinux.* stuff for now, so skip mtools-native
+DEPENDS="nasm-native"
+
+S="${WORKDIR}/syslinux-${PV}"
+
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/syslinux ${STAGING_BINDIR}
+
+ # When building media, the syslinux binary isn't nearly as useful
+ # as the DOS data files, so we copy those into a special location
+ # for usage during a image build stage
+
+ install -d ${STAGING_DATADIR}/syslinux
+ install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
+ install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
+}
diff --git a/meta/packages/syslinux/syslinux3.inc b/meta/packages/syslinux/syslinux3.inc
new file mode 100644
index 000000000..95124d616
--- /dev/null
+++ b/meta/packages/syslinux/syslinux3.inc
@@ -0,0 +1,21 @@
+require syslinux.inc
+
+STAGE_TEMP="${WORKDIR}/stage_temp"
+
+do_stage() {
+ install -d ${STAGE_TEMP}
+ oe_runmake install INSTALLROOT="${STAGE_TEMP}"
+
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
+ install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
+
+ # When building media, the syslinux binary isn't nearly as useful
+ # as the DOS data files, so we copy those into a special location
+ # for usage during a image build stage
+
+ install -d ${STAGING_DATADIR}/syslinux
+ install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
+ install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
+ install -m 644 ${S}/ldlinux.bss ${STAGING_DATADIR}/syslinux/ldlinux.bss
+}