summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-01-22 17:12:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 11:23:58 +0000
commit745bdcd3421747b050493079101f6f5ba7830daf (patch)
tree683e9713ab4b0dc2629148629b927609e0792501 /meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch
parent35c7864ee92ce38bd2992813c0ab15af9977417a (diff)
downloadopenembedded-core-745bdcd3421747b050493079101f6f5ba7830daf.tar.gz
openembedded-core-745bdcd3421747b050493079101f6f5ba7830daf.tar.bz2
openembedded-core-745bdcd3421747b050493079101f6f5ba7830daf.tar.xz
openembedded-core-745bdcd3421747b050493079101f6f5ba7830daf.zip
pciutils: upgrade to 3.1.9
Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch')
-rw-r--r--meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch b/meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch
new file mode 100644
index 000000000..540b4a0d1
--- /dev/null
+++ b/meta/recipes-bsp/pciutils/pciutils-3.1.9/guess-fix.patch
@@ -0,0 +1,37 @@
+the original guess algorithm is broken for many archs
+for example, the following two would break:
+ arm-linux-gnueabi --> sys=gnueabi
+ x86_64-unknown-pc-linux-gnu --> sys = pc-linux-gnu
+
+use a simpler scheme here and hope it works for all the cases
+
+Upstream-Status: Pending
+
+7/30/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/lib/configure b/lib/configure
+index 4318b05..84f6acb 100755
+--- a/lib/configure
++++ b/lib/configure
+@@ -53,20 +53,7 @@ cpu=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\1/'`
+ sys=`echo $host | sed 's/^\([^-]*\)-\([^-]*\)-\(.*\)$/\3/'`
+ echo " $host $rel $cpu $sys"
+
+-if [ "$host" = "linux--gnueabi" ]
+-then
+- sys=linux
+-fi
+-
+-if [ "$host" = "linux--uclibc" ]
+-then
+- sys=linux
+-fi
+-
+-if [ "$host" = "linux--uclibceabi" ]
+-then
+- sys=linux
+-fi
++{ echo "$host" | grep linux; } && sys=linux
+
+ c=config.h
+ m=config.mk