summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2011-12-11 14:47:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-13 12:21:05 +0000
commite9899d52ade2181bd97dcf79bec64650e8b0f718 (patch)
treec1d857ff3a16c1a5e3343dd1a57858fb461ee0fb /meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
parentc96db08915a554fb5e4bb2c360b919c8392b32c6 (diff)
downloadopenembedded-core-e9899d52ade2181bd97dcf79bec64650e8b0f718.tar.gz
openembedded-core-e9899d52ade2181bd97dcf79bec64650e8b0f718.tar.bz2
openembedded-core-e9899d52ade2181bd97dcf79bec64650e8b0f718.tar.xz
openembedded-core-e9899d52ade2181bd97dcf79bec64650e8b0f718.zip
u-boot: renamed dir from uboot to the more appropriate u-boot
recipe dirs normally have the name of the (main) package and the official name is u-boot Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
new file mode 100644
index 000000000..3ca0c2cfc
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2011.06.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+SECTION = "bootloader"
+
+PR = "r0"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "0cc5026aad02f218a9b9ac56b301c97a"
+SRC_URI[sha256sum] = "362ddb935885da98cf461eba08f31e3e59d0c4ada6cb2fa15596f43af310ba8b"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+BBCLASSEXTEND = "native nativesdk"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+