summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb
diff options
context:
space:
mode:
authorIlya Yanok <yanok@emcraft.com>2011-06-28 16:54:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 17:13:12 +0100
commit8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216 (patch)
treeb95a60b99bf0d3b51be23c5cb521b8b4a6b5daa6 /meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb
parent8ee5160e8978d73ade2830c9f64df4c0009c0525 (diff)
downloadopenembedded-core-8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216.tar.gz
openembedded-core-8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216.tar.bz2
openembedded-core-8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216.tar.xz
openembedded-core-8a5c20417d4d6bee6dd0bcdbeb8d4f9e0696a216.zip
[PATCH] u-boot-mkimage: bump version to 2011.03
This patch changes u-boot-mkimage version to 2011.03. Unfortunately U-Boot 2011.03 release has some problems building tools from unconfigured tree, so this patch aslo includes the backported fixes. Signed-off-by: Ilya Yanok <yanok@emcraft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb b/meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb
new file mode 100644
index 000000000..34bae8e3e
--- /dev/null
+++ b/meta/recipes-bsp/uboot/u-boot-mkimage_2011.03.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "U-boot bootloader mkimage tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
+SECTION = "bootloader"
+
+PR = "r1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://0001-Drop-config.h-include-in-tools-imximage.h.patch \
+ file://0002-config.mk-move-LDSCRIPT-processing-to-the-top-level-.patch"
+
+SRC_URI[md5sum] = "91d02124c94368557d0e9ac05fb8c33f"
+SRC_URI[sha256sum] = "08677f66d8d4ee542f6599f580cdffdf730544e1803f9d3739117d6f6d68083e"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+BBCLASSEXTEND = "native nativesdk"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true'
+
+do_compile () {
+ oe_runmake tools
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
+}
+