summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/uboot/u-boot_git.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-05-17 14:44:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-27 16:36:06 +0100
commitc7a198d7472b4767047dbbfeecb4d941055262b3 (patch)
tree1949d3957d92090194c5ef604e8c4f661d749046 /meta/recipes-bsp/uboot/u-boot_git.bb
parent4c3490922c3bea5f9c9810bb40dc5f5d8783de5a (diff)
downloadopenembedded-core-c7a198d7472b4767047dbbfeecb4d941055262b3.tar.gz
openembedded-core-c7a198d7472b4767047dbbfeecb4d941055262b3.tar.bz2
openembedded-core-c7a198d7472b4767047dbbfeecb4d941055262b3.tar.xz
openembedded-core-c7a198d7472b4767047dbbfeecb4d941055262b3.zip
u-boot: remove UBOOT_MACHINE and COMPATIBLE_MACHINES
oe-core does not define any machines, so it does not make sense to add machine specific information in the oe-core u-boot recipe and infrastructure. Also note that COMPATIBLE_MACHINES is not easily extended due to its regex syntax: "(machine_a|machine_b)", making it difficult to extend the u-boot recipe in bbappend files without resorting to machine specific overrides. Remove COMPATIBLE_MACHINES and the default UBOOT_MACHINE from the recipe and insert some anonymous python into u-boot.inc to raise SkipPackage if UBOOT_MACHINE is not set (this ensures 'world' still works for machines that can't build u-boot). UBOOT_MACHINE must now be specified in each machine config that requires u-boot. This is an improvement over requiring machine specific overrides in every BSP layer's u-boot_git.bbappend file. For example, a beagleboard machine config currently contains: UBOOT_ENTRYPOINT = "0x80008000" UBOOT_LOADADDRESS = "0x80008000" With this change, it must now contain: UBOOT_MACHINE = "omap3_beagle_config" UBOOT_ENTRYPOINT = "0x80008000" UBOOT_LOADADDRESS = "0x80008000" So long as the SRC_URI in the base recipe can build a working u-boot for a given machine, there is no need to create a u-boot_git.bbappend file. If additional patches are deemed necessary, a BSP layer creates a u-boot_git.bbappend file and extends the SRC_URI to include general or machine specific backports. Note: I used bb.note() instead of bb.debug() to ensure the message at least makes it to the console. From what I could gather, bb.debug() doesn't go anywhere during recipe parsing. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Koen Kooi <koen@dominion.thruhere.net> Cc: Jason Kridner <jkridner@beagleboard.org> Cc: Chris Larson <clarson@kergoth.com>
Diffstat (limited to 'meta/recipes-bsp/uboot/u-boot_git.bb')
-rw-r--r--meta/recipes-bsp/uboot/u-boot_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot_git.bb b/meta/recipes-bsp/uboot/u-boot_git.bb
index 4c8f5df59..0fbb9ba18 100644
--- a/meta/recipes-bsp/uboot/u-boot_git.bb
+++ b/meta/recipes-bsp/uboot/u-boot_git.bb
@@ -1,5 +1,11 @@
require u-boot.inc
+# To build u-boot for your machine, provide the following lines in your machine
+# config, replacing the assignments as appropriate for your machine.
+# UBOOT_MACHINE = "omap3_beagle_config"
+# UBOOT_ENTRYPOINT = "0x80008000"
+# UBOOT_LOADADDRESS = "0x80008000"
+
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
file://README;beginline=1;endline=22;md5=3a00ef51d3fc96e9d6c1bc4708ccd3b5"
@@ -12,11 +18,6 @@ PR="r3"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
-UBOOT_MACHINE_beagleboard = "omap3_beagle_config"
-UBOOT_MACHINE_overo = "omap3_overo_config"
-
S = "${WORKDIR}/git"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-COMPATIBLE_MACHINE = "(beagleboard|overo)"