summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp/usbutils/usbutils_0.91.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-18 14:37:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-19 20:50:50 +0100
commit0e56f8a4cd0cfa0e08ed2dd091ec209d4f0f1a7f (patch)
tree6687e6d57af83d7c05b766bff82eb11e1ed885f7 /meta/recipes-bsp/usbutils/usbutils_0.91.bb
parent68d301e950c06eda8c8a73db1ed299c45dee7b9f (diff)
downloadopenembedded-core-0e56f8a4cd0cfa0e08ed2dd091ec209d4f0f1a7f.tar.gz
openembedded-core-0e56f8a4cd0cfa0e08ed2dd091ec209d4f0f1a7f.tar.bz2
openembedded-core-0e56f8a4cd0cfa0e08ed2dd091ec209d4f0f1a7f.tar.xz
openembedded-core-0e56f8a4cd0cfa0e08ed2dd091ec209d4f0f1a7f.zip
usbutils: Update to 0.91
Also move the upstream location to kernel.org Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/usbutils/usbutils_0.91.bb')
-rw-r--r--meta/recipes-bsp/usbutils/usbutils_0.91.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/usbutils/usbutils_0.91.bb b/meta/recipes-bsp/usbutils/usbutils_0.91.bb
new file mode 100644
index 000000000..c4f40e9df
--- /dev/null
+++ b/meta/recipes-bsp/usbutils/usbutils_0.91.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Host side USB console utilities."
+DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus."
+HOMEPAGE = "http://www.linux-usb.org"
+SECTION = "base"
+PRIORITY = "optional"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "libusb zlib"
+RDEPENDS_${PN} = "${PN}-ids"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "49de2403b40bf3a9863faaa8d3858deb"
+SRC_URI[sha256sum] = "c122346b0225121bcf159abf804116f826a4a3462c94ce7b8871f7559e6b3a46"
+
+inherit autotools
+
+do_install_append() {
+ ln -s ../sbin/lsusb ${D}${bindir}/lsusb
+ # We only need the compressed copy, remove the uncompressed version
+ rm -f ${D}${datadir}/usb.ids
+}
+
+PACKAGES += "${PN}-ids"
+FILES_${PN} += "${datadir}/pkgconfig"
+FILES_${PN}-ids = "${datadir}/usb*"