summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-11-17 14:20:58 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:27 -0800
commit5c1e52c1fe452fbbd60abb68086efb6fcdd7a63b (patch)
tree7c2c60787c3f098a98e85ecaf52a39fe3f4ee9ac /meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch
parent9600b79f279a9fdc6a409e48370a18b1b3f4157b (diff)
downloadopenembedded-core-5c1e52c1fe452fbbd60abb68086efb6fcdd7a63b.tar.gz
openembedded-core-5c1e52c1fe452fbbd60abb68086efb6fcdd7a63b.tar.bz2
openembedded-core-5c1e52c1fe452fbbd60abb68086efb6fcdd7a63b.tar.xz
openembedded-core-5c1e52c1fe452fbbd60abb68086efb6fcdd7a63b.zip
openssl: upgrade to version 0.9.8p
from 0.9.8o Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch b/meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch
new file mode 100644
index 000000000..38923b08b
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-0.9.8p/debian/pkg-config.patch
@@ -0,0 +1,34 @@
+Index: openssl-0.9.8k/Makefile.org
+===================================================================
+--- openssl-0.9.8k.orig/Makefile.org 2009-07-19 11:34:56.000000000 +0200
++++ openssl-0.9.8k/Makefile.org 2009-07-19 11:36:02.000000000 +0200
+@@ -444,7 +444,8 @@
+ echo 'Description: OpenSSL cryptography library'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
+
+ libssl.pc: Makefile
+@@ -457,7 +458,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl'; \
++ echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
+
+ openssl.pc: Makefile
+@@ -470,7 +472,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
+
+ Makefile: Makefile.org Configure config