summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-03-19 23:11:25 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-21 14:05:09 +0000
commit50d99fc8c5a158c7f3ce3e72377827f53406d88f (patch)
treedc2045d34fc79645bca8788348b9c1ce4ff56663 /meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch
parent69f019c48b40ac3b7a8bce2da819f03072e78020 (diff)
downloadopenembedded-core-50d99fc8c5a158c7f3ce3e72377827f53406d88f.tar.gz
openembedded-core-50d99fc8c5a158c7f3ce3e72377827f53406d88f.tar.bz2
openembedded-core-50d99fc8c5a158c7f3ce3e72377827f53406d88f.tar.xz
openembedded-core-50d99fc8c5a158c7f3ce3e72377827f53406d88f.zip
openssl: upgrade to 1.0.0.h
Removed pkg-config.patch, which was incorporated upstream. Addresses CVE-2012-0884. Fixes bug [YOCTO #2139]. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch b/meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch
new file mode 100644
index 000000000..09986731a
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-1.0.0h/shared-libs.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: openssl-1.0.0/crypto/Makefile
+===================================================================
+--- openssl-1.0.0.orig/crypto/Makefile
++++ openssl-1.0.0/crypto/Makefile
+@@ -104,7 +104,7 @@
+
+ shared: buildinf.h lib subdirs
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ libs:
+Index: openssl-1.0.0/Makefile.org
+===================================================================
+--- openssl-1.0.0.orig/Makefile.org
++++ openssl-1.0.0/Makefile.org
+@@ -260,7 +260,7 @@
+
+ libcrypto$(SHLIB_EXT): libcrypto.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+- $(MAKE) SHLIBDIRS=crypto build-shared; \
++ $(MAKE) -e SHLIBDIRS=crypto build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2; \
+ exit 1; \
+@@ -268,7 +268,7 @@
+
+ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
++ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2; \
+ exit 1; \
+Index: openssl-1.0.0/ssl/Makefile
+===================================================================
+--- openssl-1.0.0.orig/ssl/Makefile
++++ openssl-1.0.0/ssl/Makefile
+@@ -62,7 +62,7 @@
+
+ shared: lib
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ files: