summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-04-24 22:13:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-25 09:21:19 +0100
commit88d17caf6d0eb241f54b1af1704405d5f47eadc5 (patch)
treed4920ef038ff8a7df902fe5432b0c31e60cd72f5 /meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch
parenta2009fd8548d818c4e647dae554b98074bd3eecd (diff)
downloadopenembedded-core-88d17caf6d0eb241f54b1af1704405d5f47eadc5.tar.gz
openembedded-core-88d17caf6d0eb241f54b1af1704405d5f47eadc5.tar.bz2
openembedded-core-88d17caf6d0eb241f54b1af1704405d5f47eadc5.tar.xz
openembedded-core-88d17caf6d0eb241f54b1af1704405d5f47eadc5.zip
openssl: upgrade to 1.0.0i
Addresses CVE-2012-2110 Fixes bug [YOCTO #2368] Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch b/meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch
new file mode 100644
index 000000000..09986731a
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-1.0.0i/shared-libs.patch
@@ -0,0 +1,50 @@
+Upstream-Status: Inappropriate [configuration]
+
+Index: openssl-1.0.0/crypto/Makefile
+===================================================================
+--- openssl-1.0.0.orig/crypto/Makefile
++++ openssl-1.0.0/crypto/Makefile
+@@ -104,7 +104,7 @@
+
+ shared: buildinf.h lib subdirs
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ libs:
+Index: openssl-1.0.0/Makefile.org
+===================================================================
+--- openssl-1.0.0.orig/Makefile.org
++++ openssl-1.0.0/Makefile.org
+@@ -260,7 +260,7 @@
+
+ libcrypto$(SHLIB_EXT): libcrypto.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+- $(MAKE) SHLIBDIRS=crypto build-shared; \
++ $(MAKE) -e SHLIBDIRS=crypto build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2; \
+ exit 1; \
+@@ -268,7 +268,7 @@
+
+ libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
+ @if [ "$(SHLIB_TARGET)" != "" ]; then \
+- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
++ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
+ else \
+ echo "There's no support for shared libraries on this platform" >&2; \
+ exit 1; \
+Index: openssl-1.0.0/ssl/Makefile
+===================================================================
+--- openssl-1.0.0.orig/ssl/Makefile
++++ openssl-1.0.0/ssl/Makefile
+@@ -62,7 +62,7 @@
+
+ shared: lib
+ if [ -n "$(SHARED_LIBS)" ]; then \
+- (cd ..; $(MAKE) $(SHARED_LIB)); \
++ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
+ fi
+
+ files: