summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-01-16 17:54:42 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:53:04 +0000
commit294e808d12131412bf1edb6f4babc9e57c8141e0 (patch)
tree566dd168453ba85b69035c0b21fafd0f567de2da /meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
parent980ba5e77438c3a22c295f56ffb71f1d290db50a (diff)
downloadopenembedded-core-294e808d12131412bf1edb6f4babc9e57c8141e0.tar.gz
openembedded-core-294e808d12131412bf1edb6f4babc9e57c8141e0.tar.bz2
openembedded-core-294e808d12131412bf1edb6f4babc9e57c8141e0.tar.xz
openembedded-core-294e808d12131412bf1edb6f4babc9e57c8141e0.zip
openssl-1.0.0: Update to 1.0.0e and fix QA Warning
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-4108 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-4576 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-4577 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2011-4619 http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-0027 [YOCTO #1905] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.0f.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.0f.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
new file mode 100644
index 000000000..f3404d608
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
@@ -0,0 +1,46 @@
+require openssl.inc
+
+# For target side versions of openssl enable support for OCF Linux driver
+# if they are available.
+DEPENDS += "ocf-linux"
+
+CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
+
+PR = "${INC_PR}.0"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
+
+export DIRS = "crypto ssl apps engines"
+export OE_LDFLAGS="${LDFLAGS}"
+
+SRC_URI += "file://configure-targets.patch \
+ file://shared-libs.patch \
+ file://oe-ldflags.patch \
+ file://engines-install-in-libdir-ssl.patch \
+ file://openssl-fix-link.patch \
+ file://debian/version-script.patch \
+ file://debian/pic.patch \
+ file://debian/c_rehash-compat.patch \
+ file://debian/ca.patch \
+ file://debian/make-targets.patch \
+ file://debian/no-rpath.patch \
+ file://debian/man-dir.patch \
+ file://debian/man-section.patch \
+ file://debian/pkg-config.patch \
+ file://debian/no-symbolic.patch \
+ file://debian/debian-targets.patch \
+ file://openssl_fix_for_x32.patch \
+ "
+
+SRC_URI[md5sum] = "e358705fb4a8827b5e9224a73f442025"
+SRC_URI[sha256sum] = "faf1eab0ef85fd6c3beca271c356b31b5cc831e2c6b7f23cf672e7ab4680fde1"
+
+PACKAGES =+ " \
+ ${PN}-engines \
+ ${PN}-engines-dbg \
+ "
+
+FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
+FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
+
+PARALLEL_MAKEINST = ""