summaryrefslogtreecommitdiff
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2012-01-11 11:06:19 -0800
committerSaul Wold <sgw@linux.intel.com>2012-01-19 01:16:28 -0800
commit0afa9a63a83ee128dac522af70e1f823b7d6a6df (patch)
tree28110bfb38f524271c620232cb11360f509a3ffb /meta/recipes-core/busybox
parentbbf44dddcc473ca085fa5b2dda5f89c22ec31cc0 (diff)
downloadopenembedded-core-0afa9a63a83ee128dac522af70e1f823b7d6a6df.tar.gz
openembedded-core-0afa9a63a83ee128dac522af70e1f823b7d6a6df.tar.bz2
openembedded-core-0afa9a63a83ee128dac522af70e1f823b7d6a6df.tar.xz
openembedded-core-0afa9a63a83ee128dac522af70e1f823b7d6a6df.zip
busybox: enable dropping of duplicates in syslog, off by default
Busybox syslog includes functionality to drop duplicated syslog entries, enable this feature in the defconfig yet disable it by default. Expose configuration of the feature through the syslog-startup.conf file and the syslog init script. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox-1.19.3/defconfig2
-rw-r--r--meta/recipes-core/busybox/busybox_1.19.3.bb2
-rw-r--r--meta/recipes-core/busybox/files/syslog3
-rw-r--r--meta/recipes-core/busybox/files/syslog-startup.conf1
4 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-core/busybox/busybox-1.19.3/defconfig b/meta/recipes-core/busybox/busybox-1.19.3/defconfig
index ebd751d74..b474ad408 100644
--- a/meta/recipes-core/busybox/busybox-1.19.3/defconfig
+++ b/meta/recipes-core/busybox/busybox-1.19.3/defconfig
@@ -997,7 +997,7 @@ CONFIG_FEATURE_SH_HISTFILESIZE=y
CONFIG_SYSLOGD=y
CONFIG_FEATURE_ROTATE_LOGFILE=y
CONFIG_FEATURE_REMOTE_LOG=y
-# CONFIG_FEATURE_SYSLOGD_DUP is not set
+CONFIG_FEATURE_SYSLOGD_DUP=y
CONFIG_FEATURE_SYSLOGD_CFG=y
CONFIG_FEATURE_SYSLOGD_READ_BUFFER_SIZE=256
CONFIG_FEATURE_IPC_SYSLOG=y
diff --git a/meta/recipes-core/busybox/busybox_1.19.3.bb b/meta/recipes-core/busybox/busybox_1.19.3.bb
index f591856a3..a0754071d 100644
--- a/meta/recipes-core/busybox/busybox_1.19.3.bb
+++ b/meta/recipes-core/busybox/busybox_1.19.3.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://udhcpscript.patch \
diff --git a/meta/recipes-core/busybox/files/syslog b/meta/recipes-core/busybox/files/syslog
index deeea8ba6..2944d3d06 100644
--- a/meta/recipes-core/busybox/files/syslog
+++ b/meta/recipes-core/busybox/files/syslog
@@ -40,6 +40,9 @@ if [ -f /etc/syslog-startup.conf ]; then
if [ "$REDUCE" = "yes" ]; then
SYSLOG_ARGS="$SYSLOG_ARGS -S"
fi
+ if [ "$DROPDUPLICATES" = "yes" ]; then
+ SYSLOG_ARGS="$SYSLOG_ARGS -D"
+ fi
if [ -n "$LOGLEVEL" ]; then
SYSLOG_ARGS="$SYSLOG_ARGS -l $LOGLEVEL"
fi
diff --git a/meta/recipes-core/busybox/files/syslog-startup.conf b/meta/recipes-core/busybox/files/syslog-startup.conf
index 553490bd7..fda450aa0 100644
--- a/meta/recipes-core/busybox/files/syslog-startup.conf
+++ b/meta/recipes-core/busybox/files/syslog-startup.conf
@@ -5,6 +5,7 @@ DESTINATION=file # log destinations (buffer file remote)
LOGFILE=/var/log/messages # where to log (file)
REMOTE=loghost:514 # where to log (syslog remote)
REDUCE=no # reduce-size logging
+DROPDUPLICATES=no # whether to drop duplicate log entries
#ROTATESIZE=0 # rotate log if grown beyond X [kByte]
#ROTATEGENS=3 # keep X generations of rotated logs
BUFFERSIZE=64 # size of circular buffer [kByte]