summaryrefslogtreecommitdiff
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.14.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-21 15:53:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-22 16:44:51 +0100
commit2a68cf4d315cdd18766de0c75928ff17846a6cd7 (patch)
tree8e19cfc922e308e03c601848a071528186efe34e /meta/recipes-core/eglibc/cross-localedef-native_2.14.bb
parentb8c7249e10a7bba329f1977529c7bde6b969f729 (diff)
downloadopenembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.gz
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.bz2
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.xz
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.zip
eglibc: Upgrade recipes from 2.13 -> 2.14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.14.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.14.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.14.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.14.bb
new file mode 100644
index 000000000..68ef86439
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.14.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Cross locale generation tool for eglibc"
+HOMEPAGE = "http://www.eglibc.org/home"
+SECTION = "libs"
+PRIORITY = "required"
+LICENSE = "LGPL"
+
+LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
+LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=07a394b26e0902b9ffdec03765209770 \
+ file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
+ file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
+ file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
+
+
+inherit native
+inherit autotools
+
+PR = "r1"
+SRCREV="11982"
+EGLIBC_BRANCH="eglibc-2_12"
+SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
+S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
+
+do_unpack_append() {
+ bb.build.exec_func('do_move_ports', d)
+}
+
+do_move_ports() {
+ if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ rm -rf ${WORKDIR}/libc/ports
+ mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
+ fi
+}
+
+EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
+
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+}