summaryrefslogtreecommitdiff
path: root/meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-21 15:53:38 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-22 16:44:51 +0100
commit2a68cf4d315cdd18766de0c75928ff17846a6cd7 (patch)
tree8e19cfc922e308e03c601848a071528186efe34e /meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch
parentb8c7249e10a7bba329f1977529c7bde6b969f729 (diff)
downloadopenembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.gz
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.bz2
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.tar.xz
openembedded-core-2a68cf4d315cdd18766de0c75928ff17846a6cd7.zip
eglibc: Upgrade recipes from 2.13 -> 2.14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch')
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch b/meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch
new file mode 100644
index 000000000..dbf70a974
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.14/stack-protector-test.patch
@@ -0,0 +1,35 @@
+Test for -fstack-protector is compile only test. One might have the option but
+might have build the compiler with --disable-ssp which means ssp should not be
+enabled. Therefore we change the test to a link time test. It will fail if
+libssp is not available.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: libc/configure
+===================================================================
+--- libc.orig/configure
++++ libc/configure
+@@ -6937,7 +6937,7 @@ if test "${libc_cv_ssp+set}" = set; then
+ $as_echo_n "(cached) " >&6
+ else
+ if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS -Werror -fstack-protector
+- -o /dev/null -c -x c /dev/null 1>&5'
++ -o /dev/null -x c /dev/null 1>&5'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+Index: libc/configure.in
+===================================================================
+--- libc.orig/configure.in
++++ libc/configure.in
+@@ -1787,7 +1787,7 @@ AC_SUBST(fno_unit_at_a_time)
+
+ AC_CACHE_CHECK(for -fstack-protector, libc_cv_ssp, [dnl
+ if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS -Werror -fstack-protector
+- -o /dev/null -c -x c /dev/null 1>&AS_MESSAGE_LOG_FD])
++ -o /dev/null -x c /dev/null 1>&AS_MESSAGE_LOG_FD])
+ then
+ libc_cv_ssp=yes
+ else