summaryrefslogtreecommitdiff
path: root/meta/recipes-core/tasks/task-core-tools-profile.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-20 17:13:37 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:14 -0800
commit180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6 (patch)
tree16573db8f7b8a75e8cf59dc15c321f889e1edf79 /meta/recipes-core/tasks/task-core-tools-profile.bb
parentaa6293ffbc7f8f17e55f2105de56384e14591b44 (diff)
downloadopenembedded-core-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.tar.gz
openembedded-core-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.tar.bz2
openembedded-core-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.tar.xz
openembedded-core-180227d8ff71c42e0d16ad7eb4a5f9b7d6a0c1c6.zip
task-core-tools: Divide it into 3 recipes
task-core-tools-debug, task-core-tools-profile, task-core-tools-testapps otherwise if we choose one through PACKAGE_GROUPS all packages are built since they are in same recipe. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/tasks/task-core-tools-profile.bb')
-rw-r--r--meta/recipes-core/tasks/task-core-tools-profile.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools-profile.bb b/meta/recipes-core/tasks/task-core-tools-profile.bb
new file mode 100644
index 000000000..254d3f5e4
--- /dev/null
+++ b/meta/recipes-core/tasks/task-core-tools-profile.bb
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2008 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Profile tools tasks for OE-Core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dbg \
+ ${PN}-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+ALLOW_EMPTY = "1"
+
+RRECOMMENDS_${PN} = "\
+ perf \
+ trace-cmd \
+ kernel-module-oprofile \
+ blktrace \
+ sysprof \
+ "
+
+PROFILETOOLS = "\
+ oprofile \
+ oprofileui-server \
+ powertop \
+ latencytop \
+ lttng-control \
+ lttng-viewer"
+
+# systemtap needs elfutils which is not fully buildable on uclibc
+# hence we exclude it from uclibc based builds
+SYSTEMTAP = "systemtap"
+SYSTEMTAP_libc-uclibc = ""
+
+# lttng-ust uses sched_getcpu() which is not there on uclibc
+# for some of the architectures it can be patched to call the
+# syscall directly but for x86_64 __NR_getcpu is a vsyscall
+# which means we can not use syscall() to call it. So we ignore
+# it for x86_64/uclibc
+
+LTTNGUST = "lttng-ust"
+LTTNGUST_libc-uclibc = ""
+LTTNGUST_mips = ""
+
+# valgrind does not work on mips
+
+VALGRIND = "valgrind"
+VALGRIND_libc-uclibc = ""
+VALGRIND_mips = ""
+
+# exmap-console
+# exmap-server
+
+# At present we only build lttng-ust on
+# qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
+# (which is required by lttng-ust) may not build on other platforms, like
+# MIPS.
+RDEPENDS_${PN} = "\
+ ${PROFILETOOLS} \
+ ${LTTNGUST} \
+ ${SYSTEMTAP} \
+ ${VALGRIND} \
+ "