summaryrefslogtreecommitdiff
path: root/meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-01 16:16:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-07 10:50:46 +0100
commit99dcbc151676f9488e00374ef525f72854b9d459 (patch)
tree840710313c275831ef1fd1113786c972795c0980 /meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch
parent84f3ae92ab4345cc99b47e021ff960857f803d45 (diff)
downloadopenembedded-core-99dcbc151676f9488e00374ef525f72854b9d459.tar.gz
openembedded-core-99dcbc151676f9488e00374ef525f72854b9d459.tar.bz2
openembedded-core-99dcbc151676f9488e00374ef525f72854b9d459.tar.xz
openembedded-core-99dcbc151676f9488e00374ef525f72854b9d459.zip
uclibc: Add recipes for 0.9.32 release
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch')
-rw-r--r--meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch b/meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch
new file mode 100644
index 000000000..429f27dfc
--- /dev/null
+++ b/meta/recipes-core/uclibc/uclibc-0.9.32/compile-arm-fork-with-O2.patch
@@ -0,0 +1,21 @@
+When compiling in thumb mode for arm with -Os gcc gives up since it can not find registers
+to spill. So we use -O2 option for compiling fork.c It may be addressable is gcc.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch b/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
+index 329d8a9..41e3646 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/arm/Makefile.arch
+@@ -30,3 +30,9 @@ CFLAGS-OMIT-libc-lowlevellock.c = -DNOT_IN_libc -DIS_IN_libpthread
+ # This macro should be alternatively implemented in THUMB
+ # assembly.
+ ASFLAGS-vfork.S = -marm
++
++# For arm fork.c does not compile with -Os when in compiling
++# in thumb1 mode
++ifeq ($(COMPILE_IN_THUMB_MODE),y)
++CFLAGS-fork.c = -O2
++endif