summaryrefslogtreecommitdiff
path: root/meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-01 14:45:39 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:46 +0000
commitfdaf4e791fcacb48ea430ec768ad9a6919c65ce0 (patch)
tree35ebc9d1c87395c226aaae3c3c40ba2f6c3b27bf /meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch
parent61620bd56d0696a03ffc94fbbfa2d0e25be950a5 (diff)
downloadopenembedded-core-fdaf4e791fcacb48ea430ec768ad9a6919c65ce0.tar.gz
openembedded-core-fdaf4e791fcacb48ea430ec768ad9a6919c65ce0.tar.bz2
openembedded-core-fdaf4e791fcacb48ea430ec768ad9a6919c65ce0.tar.xz
openembedded-core-fdaf4e791fcacb48ea430ec768ad9a6919c65ce0.zip
util-linux: Update to 2.20.1
Add patch remove setting CC, LD and LDFLAGS on commandline since they are passed correctly via configure. Those setting also caused the configure information about -std=gnu99 from being passed correctly. Removed patch that was fixed upstream Added scanf configuration, since this is a cross-compile target check libuuid removed an API that e2fsprogs uuidd used (uuid__generate_*), thus we disable it in this patch and will now provide uuidd from util-linux. See http://sourceforge.net/projects/e2fsprogs/forums/forum/7053/topic/4639484 Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch')
-rw-r--r--meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch b/meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch
new file mode 100644
index 000000000..45826b180
--- /dev/null
+++ b/meta/recipes-core/util-linux/util-linux-2.20.1/uclibc-__progname-conflict.patch
@@ -0,0 +1,31 @@
+configure should include errno.h instead of argp.h when
+checking for presence of program_invocation_short_name
+uclibc defines this to be const char* unlike util-linux-ng
+which defines this to be char* so this error goes unnoticed
+on glibc/eglibc systems.
+
+here is the error it fixes
+
+in file included from mountP.h:14:0,
+ from cache.c:29:
+/home/kraj/work/slugos/build/tmp-slugos-uclibc/sysroots/nslu2le/usr/include/errno.h:55:46: error: conflicting types for '__progname'
+../../../include/c.h:118:14: note: previous declaration of '__progname' was here
+make[3]: *** [cache.lo] Error 1
+
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: util-linux-2.19.1/configure.ac
+===================================================================
+--- util-linux-2.19.1.orig/configure.ac
++++ util-linux-2.19.1/configure.ac
+@@ -250,7 +250,7 @@ esac
+
+
+ AC_MSG_CHECKING(whether program_invocation_short_name is defined)
+-AC_TRY_COMPILE([#include <argp.h>],
++AC_TRY_COMPILE([#include <errno.h>],
+ [program_invocation_short_name = "test";],
+ AC_DEFINE(HAVE_PROGRAM_INVOCATION_SHORT_NAME, 1,
+ [Define if program_invocation_short_name is defined])