summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/automake/automake_1.11.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-12-27 11:30:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:51 +0000
commit2dffe02af05413d8438ddc28d542dc5d85ac105f (patch)
treea481bd700243d18293a0f10a5e7d4ae290b78eaf /meta/recipes-devtools/automake/automake_1.11.2.bb
parentffb10e51dae3e360822f26d1425c3327213a7e81 (diff)
downloadopenembedded-core-2dffe02af05413d8438ddc28d542dc5d85ac105f.tar.gz
openembedded-core-2dffe02af05413d8438ddc28d542dc5d85ac105f.tar.bz2
openembedded-core-2dffe02af05413d8438ddc28d542dc5d85ac105f.tar.xz
openembedded-core-2dffe02af05413d8438ddc28d542dc5d85ac105f.zip
automake: upgrade from 1.11.1 to 1.11.2
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.2.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.2.bb b/meta/recipes-devtools/automake/automake_1.11.2.bb
new file mode 100644
index 000000000..b455edfe6
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.2.bb
@@ -0,0 +1,49 @@
+require automake.inc
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS_virtclass-native = "autoconf-native"
+
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
+
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
+
+PATHFIXPATCH = "file://path_prog_fixes.patch"
+PATHFIXPATCH_virtclass-native = ""
+PATHFIXPATCH_virtclass-nativesdk = ""
+
+SRC_URI += "${PATHFIXPATCH} \
+ file://prefer-cpio-over-pax-for-ustar-archives.patch \
+ file://python-libdir.patch"
+
+PR = "r0"
+SRC_URI[md5sum] = "18194e804d415767bae8f703c963d456"
+SRC_URI[sha256sum] = "4f46d1f9380c8a3506280750f630e9fc915cb1a435b724be56b499d016368718"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native nativesdk"