summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-02-23 16:50:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:52:56 +0000
commit6a74c2050de4540deaf4e855bdf7aec4518f648a (patch)
treea50f5e6f114dbefef03965fa7949786e798ed1b7 /meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch
parentaebdffc93ba8446bbd4e20263f0f75d4d4460c47 (diff)
downloadopenembedded-core-6a74c2050de4540deaf4e855bdf7aec4518f648a.tar.gz
openembedded-core-6a74c2050de4540deaf4e855bdf7aec4518f648a.tar.bz2
openembedded-core-6a74c2050de4540deaf4e855bdf7aec4518f648a.tar.xz
openembedded-core-6a74c2050de4540deaf4e855bdf7aec4518f648a.zip
e2fsprogs: remove ldconfig call from install-libs
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch
new file mode 100644
index 000000000..0e5fd7d3f
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/remove.ldconfig.call.patch
@@ -0,0 +1,28 @@
+When /etc/ld.so.cache is writeable by user running bitbake then it creates invalid cache
+(in my case libstdc++.so cannot be found after building zlib(-native) and I have to call
+touch */libstdc++.so && /sbin/ldconfig to fix it.
+
+So remove ldconfig call from make install-libs
+
+Upstream-Status: Inappropriate [disable feature]
+
+diff -uNr e2fsprogs-1.42.orig/lib/Makefile.elf-lib e2fsprogs-1.42/lib/Makefile.elf-lib
+--- e2fsprogs-1.42.orig/lib/Makefile.elf-lib 2010-06-14 05:07:36.000000000 +0200
++++ e2fsprogs-1.42/lib/Makefile.elf-lib 2012-02-23 14:26:07.021272275 +0100
+@@ -52,8 +52,6 @@
+ $(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
+ $(DESTDIR)$(libdir)/$(ELF_IMAGE).so; \
+ fi
+- $(E) " LDCONFIG"
+- $(Q) -$(LDCONFIG)
+
+ install-strip: install
+ $(E) " STRIP-LIB $(ELF_INSTALL_DIR)/$(ELF_LIB)"
+@@ -69,7 +67,6 @@
+ $(RM) -f $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB) \
+ $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME) \
+ $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
+- -$(LDCONFIG)
+
+ clean::
+ $(RM) -rf elfshared