summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-01-12 14:27:07 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-17 14:53:02 +0000
commit1749f35bc92acd971eda245b93781305f79c2bef (patch)
tree06c0274085316b6a5097de73837a8a4d1bc959e5 /meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42
parent1fcd483e5ee5223f37c5edce26327f79b76bd01d (diff)
downloadopenembedded-core-1749f35bc92acd971eda245b93781305f79c2bef.tar.gz
openembedded-core-1749f35bc92acd971eda245b93781305f79c2bef.tar.bz2
openembedded-core-1749f35bc92acd971eda245b93781305f79c2bef.tar.xz
openembedded-core-1749f35bc92acd971eda245b93781305f79c2bef.zip
e2fsprogs: upgrade to 1.42
Refactored quotefix.patch to apply cleanly. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/acinclude.m486
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/mkdir.patch29
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/quotefix.patch44
3 files changed, 159 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/acinclude.m4 b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/acinclude.m4
new file mode 100644
index 000000000..4b0066847
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/acinclude.m4
@@ -0,0 +1,86 @@
+# Extracted from the package's shipped aclocal.m4. Custom macros should be in
+# acinclude.m4 so running aclocal doesn't blow them away.
+#
+# RP 1/6/2010
+
+# ===========================================================================
+# http://www.nongnu.org/autoconf-archive/check_gnu_make.html
+# ===========================================================================
+#
+# SYNOPSIS
+#
+# CHECK_GNU_MAKE()
+#
+# DESCRIPTION
+#
+# This macro searches for a GNU version of make. If a match is found, the
+# makefile variable `ifGNUmake' is set to the empty string, otherwise it
+# is set to "#". This is useful for including a special features in a
+# Makefile, which cannot be handled by other versions of make. The
+# variable _cv_gnu_make_command is set to the command to invoke GNU make
+# if it exists, the empty string otherwise.
+#
+# Here is an example of its use:
+#
+# Makefile.in might contain:
+#
+# # A failsafe way of putting a dependency rule into a makefile
+# $(DEPEND):
+# $(CC) -MM $(srcdir)/*.c > $(DEPEND)
+#
+# @ifGNUmake@ ifeq ($(DEPEND),$(wildcard $(DEPEND)))
+# @ifGNUmake@ include $(DEPEND)
+# @ifGNUmake@ endif
+#
+# Then configure.in would normally contain:
+#
+# CHECK_GNU_MAKE()
+# AC_OUTPUT(Makefile)
+#
+# Then perhaps to cause gnu make to override any other make, we could do
+# something like this (note that GNU make always looks for GNUmakefile
+# first):
+#
+# if ! test x$_cv_gnu_make_command = x ; then
+# mv Makefile GNUmakefile
+# echo .DEFAULT: > Makefile ;
+# echo \ $_cv_gnu_make_command \$@ >> Makefile;
+# fi
+#
+# Then, if any (well almost any) other make is called, and GNU make also
+# exists, then the other make wraps the GNU make.
+#
+# LICENSE
+#
+# Copyright (c) 2008 John Darrington <j.darrington@elvis.murdoch.edu.au>
+#
+# Copying and distribution of this file, with or without modification, are
+# permitted in any medium without royalty provided the copyright notice
+# and this notice are preserved.
+#
+# Note: Modified by Ted Ts'o to add @ifNotGNUMake@
+
+AC_DEFUN(
+ [CHECK_GNU_MAKE], [ AC_CACHE_CHECK( for GNU make,_cv_gnu_make_command,
+ _cv_gnu_make_command='' ;
+dnl Search all the common names for GNU make
+ for a in "$MAKE" make gmake gnumake ; do
+ if test -z "$a" ; then continue ; fi ;
+ if ( sh -c "$a --version" 2> /dev/null | grep GNU 2>&1 > /dev/null ) ; then
+ _cv_gnu_make_command=$a ;
+ break;
+ fi
+ done ;
+ ) ;
+dnl If there was a GNU version, then set @ifGNUmake@ to the empty string, '#' otherwise
+ if test "x$_cv_gnu_make_command" != "x" ; then
+ ifGNUmake='' ;
+ ifNotGNUmake='#' ;
+ else
+ ifGNUmake='#' ;
+ ifNotGNUmake='' ;
+ AC_MSG_RESULT("Not found");
+ fi
+ AC_SUBST(ifGNUmake)
+ AC_SUBST(ifNotGNUmake)
+] )
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/mkdir.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/mkdir.patch
new file mode 100644
index 000000000..e91ffa96c
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/mkdir.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Mei Lei <lei.mei@intel.com>
+
+Index: e2fsprogs-1.41.5/po/Makefile.in.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/po/Makefile.in.in 2009-02-14 13:49:08.000000000 +0000
++++ e2fsprogs-1.41.5/po/Makefile.in.in 2009-08-19 17:52:31.000000000 +0100
+@@ -30,7 +30,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
++mkinstalldirs = $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
+Index: e2fsprogs-1.41.5/configure.in
+===================================================================
+--- e2fsprogs-1.41.5.orig/configure.in 2009-08-19 17:53:50.000000000 +0100
++++ e2fsprogs-1.41.5/configure.in 2009-08-19 17:48:38.000000000 +0100
+@@ -970,6 +970,8 @@
+ fi
+ AC_SUBST(BUILD_CFLAGS)
+ AC_SUBST(BUILD_LDFLAGS)
++MKINSTALLDIRS="mkdir -p"
++AC_SUBST(MKINSTALLDIRS)
+ dnl
+ dnl Make our output files, being sure that we create the some miscellaneous
+ dnl directories
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/quotefix.patch b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/quotefix.patch
new file mode 100644
index 000000000..e576f35cc
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs-1.42/quotefix.patch
@@ -0,0 +1,44 @@
+Upstream-Status: Pending
+
+These macros are underquoted and break with recent autoconf+automake
+combinations. - RP 2010-01-02
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+diff -urN e2fsprogs-1.42.orig//configure.in e2fsprogs-1.42/configure.in
+--- e2fsprogs-1.42.orig//configure.in 2011-11-28 09:28:22.000000000 -0800
++++ e2fsprogs-1.42/configure.in 2012-01-12 14:42:54.820531407 -0800
+@@ -439,11 +439,11 @@
+ AC_MSG_ERROR([pkg-config not installed; please install it.])
+ fi
+
+- AC_CHECK_LIB(uuid, uuid_generate,
++ [AC_CHECK_LIB(uuid, uuid_generate,
+ [LIBUUID=`$PKG_CONFIG --libs uuid`;
+ STATIC_LIBUUID=`$PKG_CONFIG --static --libs uuid`],
+ [AC_MSG_ERROR([external uuid library not found])],
+- [$LIBUUID])
++ [$LIBUUID])]
+ UUID_CMT=#
+ AC_MSG_RESULT([Disabling private uuid library])
+ else
+@@ -939,15 +939,15 @@
+ AH_TEMPLATE([HAVE_SEM_INIT], [Define to 1 if sem_init() exists])
+ SEM_INIT_LIB=''
+ AC_CHECK_FUNC(sem_init, ,
+- AC_CHECK_LIB(pthread, sem_init,
++ [AC_CHECK_LIB(pthread, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT, 1)
+ SEM_INIT_LIB=-lpthread,
+- AC_CHECK_LIB(rt, sem_init,
++ [AC_CHECK_LIB(rt, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT, 1)
+ SEM_INIT_LIB=-lrt,
+- AC_CHECK_LIB(posix4, sem_init,
++ [AC_CHECK_LIB(posix4, sem_init,
+ AC_DEFINE(HAVE_SEM_INIT, 1)
+- SEM_INIT_LIB=-lposix4))))dnl
++ SEM_INIT_LIB=-lposix4)])])])dnl
+ AC_SUBST(SEM_INIT_LIB)
+ dnl
+ dnl Check for unified diff