summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-12-10 14:03:42 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-12-10 22:01:31 -0800
commit082c4e2440582cf44fbc65ba97ba3577da95ff4b (patch)
tree01aed777a90db61e0c995b333c7ead87b2900636 /meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch
parent1901134554cd14e2ad9203452dce0cf4502b08be (diff)
downloadopenembedded-core-082c4e2440582cf44fbc65ba97ba3577da95ff4b.tar.gz
openembedded-core-082c4e2440582cf44fbc65ba97ba3577da95ff4b.tar.bz2
openembedded-core-082c4e2440582cf44fbc65ba97ba3577da95ff4b.tar.xz
openembedded-core-082c4e2440582cf44fbc65ba97ba3577da95ff4b.zip
fakeroot: upgrade to version 1.14.5
from 1.14.4 changes: - install to ${includedir} instead of ${STAGING_INCDIR} - fakeroot has long been under GPLv3 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch')
-rw-r--r--meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch b/meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch
new file mode 100644
index 000000000..ae18e8a28
--- /dev/null
+++ b/meta/recipes-devtools/fakeroot/fakeroot-1.14.5/absolutepaths.patch
@@ -0,0 +1,47 @@
+Image creation runs under a fakeroot context and calls a script which refers
+to the build systems's python. This loads but can find a libpython from staging
+if these are incompatible, anything can break. These scripts should *not* be
+changing LD_LIBRARY_PATH, just adding an LD_PRELOAD with an absolute path. The
+dyanmic linker can figure out anything else with rpaths.
+
+RP - 23/1/10
+
+Index: fakeroot-1.9.4/configure.ac
+===================================================================
+--- fakeroot-1.9.4.orig/configure.ac 2010-01-23 22:34:39.000000000 +0000
++++ fakeroot-1.9.4/configure.ac 2010-01-23 22:35:14.000000000 +0000
+@@ -414,6 +414,8 @@
+ ;;
+ esac
+
++LDPRELOADABS=1
++
+ AC_DEFINE_UNQUOTED([LIBCPATH], "$libcpath", [path to libc shared object])
+ AC_SUBST(DLSUFFIX)
+ AC_SUBST(LDLIBPATHVAR)
+Index: fakeroot-1.9.4/scripts/fakeroot.in
+===================================================================
+--- fakeroot-1.9.4.orig/scripts/fakeroot.in 2010-01-23 22:34:53.000000000 +0000
++++ fakeroot-1.9.4/scripts/fakeroot.in 2010-01-23 22:37:17.000000000 +0000
+@@ -135,7 +135,7 @@
+ if [ "$WAITINTRAP" -eq 0 ]; then
+ trap "kill -s @signal@ $PID" EXIT INT
+ else
+- trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
++ trap 'FAKEROOTKEY=$FAKEROOTKEY LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
+ fi
+
+ if test -z "$FAKEROOTKEY" || test -z "$PID"; then
+@@ -158,10 +158,10 @@
+ export FAKEROOT_FD_BASE
+
+ if test -z "$*"; then
+- FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
++ FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" ${SHELL:-/bin/sh}
+ RESULT=$?
+ else
+- FAKEROOTKEY=$FAKEROOTKEY @LDLIBPATHVAR@="$PATHS" @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
++ FAKEROOTKEY=$FAKEROOTKEY @LDEXTRAVAR@ @LDPRELOADVAR@="$LIB" "$@"
+ RESULT=$?
+ fi
+