summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 08:30:41 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commitb1dd356f5eab11fa6fc18013189e51c13fdd763b (patch)
treea1c8e13223ea108b88507c35dfdf0c1b9d6f1edb /meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch
parentcaf8fe37496f49ed920036ac8763ec56b0029570 (diff)
downloadopenembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.gz
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.bz2
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.xz
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.zip
gcc: upgrade from 4.5.0 to 4.5.1
Removed these patches which are not needed anymore. gcc-4.5.0_to_svn_162697.patch.bz2 : All the commits in this patch is part of the 4.5.1 branch. So moving to 4.5.1 makes this patch obsolete gcc_revert_base_version_to_4.5.0.patch: moving to 4.5.1 removes need of this patch gcc-pr43698-arm-rev-instr.patch: upstream has this fix. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch b/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch
deleted file mode 100644
index b1d5a1a3c..000000000
--- a/meta/recipes-devtools/gcc/gcc-4.5.0/disable_relax_pic_calls_flag.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-GCC: disable MASK_RELAX_PIC_CALLS bit
-
-The new feature added after 4.3.3
-"http://www.pubbs.net/200909/gcc/94048-patch-add-support-for-rmipsjalr.html"
-will cause cc1plus eat up all the system memory when build webkit-gtk.
-The function mips_get_pic_call_symbol keeps on recursively calling itself.
-Disable this feature to walk aside the bug.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-diff -ruN gcc-4.5.0-orig/gcc/configure gcc-4.5.0/gcc/configure
---- gcc-4.5.0-orig/gcc/configure 2010-09-17 23:30:21.000000000 +0800
-+++ gcc-4.5.0/gcc/configure 2010-09-19 18:21:28.000000000 +0800
-@@ -23945,13 +23945,6 @@
- rm -f conftest.*
- fi
- fi
-- if test $gcc_cv_as_ld_jalr_reloc = yes; then
-- if test x$target_cpu_default = x; then
-- target_cpu_default=MASK_RELAX_PIC_CALLS
-- else
-- target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
-- fi
-- fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $gcc_cv_as_ld_jalr_reloc" >&5
- $as_echo "$gcc_cv_as_ld_jalr_reloc" >&6; }
-
-diff -ruN gcc-4.5.0-orig/gcc/configure.ac gcc-4.5.0/gcc/configure.ac
---- gcc-4.5.0-orig/gcc/configure.ac 2010-09-17 23:30:21.000000000 +0800
-+++ gcc-4.5.0/gcc/configure.ac 2010-09-19 18:21:11.000000000 +0800
-@@ -3467,13 +3467,6 @@
- rm -f conftest.*
- fi
- fi
-- if test $gcc_cv_as_ld_jalr_reloc = yes; then
-- if test x$target_cpu_default = x; then
-- target_cpu_default=MASK_RELAX_PIC_CALLS
-- else
-- target_cpu_default="($target_cpu_default)|MASK_RELAX_PIC_CALLS"
-- fi
-- fi
- AC_MSG_RESULT($gcc_cv_as_ld_jalr_reloc)
-
- AC_CACHE_CHECK([linker for .eh_frame personality relaxation],