summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch
diff options
context:
space:
mode:
authorKumar Gala <galak@kernel.crashing.org>2011-08-26 09:33:53 -0500
committerSaul Wold <sgw@linux.intel.com>2011-08-26 12:23:56 -0700
commitfef385e37e82a0eec743fbd1da11021b9e7158b5 (patch)
tree4ffc3e7e18749853226beab8ac2aaaf571b010b6 /meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch
parent0fabe078a31591f41c3fdabe5aa9de1111ef82c7 (diff)
downloadopenembedded-core-fef385e37e82a0eec743fbd1da11021b9e7158b5.tar.gz
openembedded-core-fef385e37e82a0eec743fbd1da11021b9e7158b5.tar.bz2
openembedded-core-fef385e37e82a0eec743fbd1da11021b9e7158b5.tar.xz
openembedded-core-fef385e37e82a0eec743fbd1da11021b9e7158b5.zip
gcc-4.5.1: Drop gcc-poison-parameters.patch, replace with bug fix patch
The gcc-poison-parameters was added specifically to deal with an issue on ppc targets and a bug when we build with -Os -frename-registers. This bug below reports the issue and is fixed in gcc-4.6.x/mainline: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44618 Backport patch to gcc 4.5.1. Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch85
1 files changed, 0 insertions, 85 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch b/meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch
deleted file mode 100644
index 74d45277e..000000000
--- a/meta/recipes-devtools/gcc/gcc-4.5.1/gcc-poison-parameters.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-Upstream-Status: Pending
-
-gcc: add poison parameters detection
-
-Add the logic that, if not configured with "--enable-target-optspace",
-gcc will meet error when build target app with "-Os" option.
-This could avoid potential binary crash.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-diff --git a/gcc/config.in b/gcc/config.in
-index a9e208f..3004321 100644
---- a/gcc/config.in
-+++ b/gcc/config.in
-@@ -132,6 +132,12 @@
- #endif
-
-
-+/* Define to enable target optspace support. */
-+#ifndef USED_FOR_TARGET
-+#undef ENABLE_TARGET_OPTSPACE
-+#endif
-+
-+
- /* Define if you want all operations on RTL (the basic data structure of the
- optimizer and back end) to be checked for dynamic type safety at runtime.
- This is quite expensive. */
-diff --git a/gcc/configure b/gcc/configure
-index 2e022ed..004ec0b 100755
---- a/gcc/configure
-+++ b/gcc/configure
-@@ -909,6 +909,7 @@ enable_maintainer_mode
- enable_version_specific_runtime_libs
- with_slibdir
- enable_plugin
-+enable_target_optspace
- '
- ac_precious_vars='build_alias
- host_alias
-@@ -25289,6 +25290,13 @@ $as_echo "#define ENABLE_PLUGIN 1" >>confdefs.h
-
- fi
-
-+if test x"$enable_target_optspace" != x; then :
-+
-+$as_echo "#define ENABLE_TARGET_OPTSPACE 1" >>confdefs.h
-+
-+fi
-+
-+
- # Configure the subdirectories
- # AC_CONFIG_SUBDIRS($subdirs)
-
-diff --git a/gcc/configure.ac b/gcc/configure.ac
-index ac4ca70..18ec0aa 100644
---- a/gcc/configure.ac
-+++ b/gcc/configure.ac
-@@ -4434,6 +4434,11 @@ if test x"$enable_plugin" = x"yes"; then
- AC_DEFINE(ENABLE_PLUGIN, 1, [Define to enable plugin support.])
- fi
-
-+AC_SUBST(enable_target_optspace)
-+if test x"$enable_target_optspace" != x; then
-+ AC_DEFINE(ENABLE_TARGET_OPTSPACE, 1, [Define to enable target optspace support.])
-+fi
-+
- # Configure the subdirectories
- # AC_CONFIG_SUBDIRS($subdirs)
-
-diff --git a/gcc/opts.c b/gcc/opts.c
-index 139cd26..2fdd96a 100644
---- a/gcc/opts.c
-+++ b/gcc/opts.c
-@@ -945,6 +945,11 @@ decode_options (unsigned int argc, const char **argv)
- else
- set_param_value ("min-crossjump-insns", initial_min_crossjump_insns);
-
-+#ifndef ENABLE_TARGET_OPTSPACE
-+ if (optimize_size == 1)
-+ error ("Do not use -Os option if --enable-target-optspace is not set.");
-+#endif
-+
- if (first_time_p)
- {
- /* Initialize whether `char' is signed. */