summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 08:30:41 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commitb1dd356f5eab11fa6fc18013189e51c13fdd763b (patch)
treea1c8e13223ea108b88507c35dfdf0c1b9d6f1edb /meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch
parentcaf8fe37496f49ed920036ac8763ec56b0029570 (diff)
downloadopenembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.gz
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.bz2
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.tar.xz
openembedded-core-b1dd356f5eab11fa6fc18013189e51c13fdd763b.zip
gcc: upgrade from 4.5.0 to 4.5.1
Removed these patches which are not needed anymore. gcc-4.5.0_to_svn_162697.patch.bz2 : All the commits in this patch is part of the 4.5.1 branch. So moving to 4.5.1 makes this patch obsolete gcc_revert_base_version_to_4.5.0.patch: moving to 4.5.1 removes need of this patch gcc-pr43698-arm-rev-instr.patch: upstream has this fix. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch b/meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch
new file mode 100644
index 000000000..4b827d639
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-4.5.1/zecke-xgcc-cpp.patch
@@ -0,0 +1,28 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
+Index: gcc-4.5.0/Makefile.in
+===================================================================
+--- gcc-4.5.0.orig/Makefile.in 2010-02-17 03:01:44.000000000 -0800
++++ gcc-4.5.0/Makefile.in 2010-06-25 11:22:08.421381364 -0700
+@@ -266,6 +266,7 @@
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+Index: gcc-4.5.0/Makefile.tpl
+===================================================================
+--- gcc-4.5.0.orig/Makefile.tpl 2010-02-17 03:01:44.000000000 -0800
++++ gcc-4.5.0/Makefile.tpl 2010-06-25 11:22:16.945631990 -0700
+@@ -269,6 +269,7 @@
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \