summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-17 17:11:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-23 11:49:04 +0100
commit68b545f4ff719f2b6e57d68b002dc9845c7a14ae (patch)
treef21182fa4d1394686b9afafbaac6d90bc3aa69a8 /meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
parentb32666e29999c7c698b1a1378f96844fbc48358d (diff)
downloadopenembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.gz
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.bz2
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.xz
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.zip
gcc-4.6: Switch to using svn SRC_URI for recipe
We call the recipes 4.6 Remove the backport patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch b/meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
new file mode 100644
index 000000000..6192c4820
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-4.6/zecke-xgcc-cpp.patch
@@ -0,0 +1,30 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
+Index: gcc-4.6.0/Makefile.in
+===================================================================
+--- gcc-4.6.0.orig/Makefile.in
++++ gcc-4.6.0/Makefile.in
+@@ -270,6 +270,7 @@ BASE_TARGET_EXPORTS = \
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
+Index: gcc-4.6.0/Makefile.tpl
+===================================================================
+--- gcc-4.6.0.orig/Makefile.tpl
++++ gcc-4.6.0/Makefile.tpl
+@@ -273,6 +273,7 @@ BASE_TARGET_EXPORTS = \
+ AR="$(AR_FOR_TARGET)"; export AR; \
+ AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
+ CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
++ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
+ CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
+ CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
+ CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \