summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-06-17 17:11:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-23 11:49:04 +0100
commit68b545f4ff719f2b6e57d68b002dc9845c7a14ae (patch)
treef21182fa4d1394686b9afafbaac6d90bc3aa69a8 /meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
parentb32666e29999c7c698b1a1378f96844fbc48358d (diff)
downloadopenembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.gz
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.bz2
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.tar.xz
openembedded-core-68b545f4ff719f2b6e57d68b002dc9845c7a14ae.zip
gcc-4.6: Switch to using svn SRC_URI for recipe
We call the recipes 4.6 Remove the backport patches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
new file mode 100644
index 000000000..da3210fc3
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
@@ -0,0 +1,23 @@
+inherit cross-canadian
+
+require gcc-${PV}.inc
+require gcc-cross-canadian.inc
+require gcc-configure-sdk.inc
+require gcc-package-sdk.inc
+
+DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
+RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
+
+SYSTEMHEADERS = "/usr/include"
+SYSTEMLIBS = "/lib/"
+SYSTEMLIBS1 = "/usr/lib/"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+# to find libmpfr
+# export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}"
+
+PARALLEL_MAKE = ""