summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/gcc/libgcc_4.6.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-23 19:07:46 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 14:48:48 +0100
commit7cf9f0597648c0bdaa080976d74acfbfc4c8443d (patch)
tree14766144daa76a935eb970bf250cd20a334cdb72 /meta/recipes-devtools/gcc/libgcc_4.6.bb
parent0e904103e9bd7fdb31bfcc129067511f9f45701b (diff)
downloadopenembedded-core-7cf9f0597648c0bdaa080976d74acfbfc4c8443d.tar.gz
openembedded-core-7cf9f0597648c0bdaa080976d74acfbfc4c8443d.tar.bz2
openembedded-core-7cf9f0597648c0bdaa080976d74acfbfc4c8443d.tar.xz
openembedded-core-7cf9f0597648c0bdaa080976d74acfbfc4c8443d.zip
gcc: Stash the gcc-cross builddir to reuse in libgcc and gcc-runtime
Currently we stash the libgcc install tree and then reuse that to populate libgcc recipe later. This mechanism does not work for gcc 4.7/trunk since now libstdc++ needs access to build tree of libgcc. This patch stashes the gcc-cross build tree and then reuses this in libgcc as well as in gcc-runtime recipe builds. Now we build libgcc in the libgcc recipe instead of just using the prebuilt install tree core-image-minimal build/run tested on all qemu machines Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/libgcc_4.6.bb')
-rw-r--r--meta/recipes-devtools/gcc/libgcc_4.6.bb33
1 files changed, 24 insertions, 9 deletions
diff --git a/meta/recipes-devtools/gcc/libgcc_4.6.bb b/meta/recipes-devtools/gcc/libgcc_4.6.bb
index 9a8b20d87..9db724353 100644
--- a/meta/recipes-devtools/gcc/libgcc_4.6.bb
+++ b/meta/recipes-devtools/gcc/libgcc_4.6.bb
@@ -1,6 +1,7 @@
require gcc-${PV}.inc
INHIBIT_DEFAULT_DEPS = "1"
+
DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
PKGSUFFIX = ""
@@ -23,15 +24,26 @@ FILES_libgcov${PKGSUFFIX}-dev = " \
FILES_${PN}-dbg += "${base_libdir}/.debug/"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install () {
+do_configure () {
target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
-
- # Install libgcc from our gcc-cross saved data
install -d ${D}${base_libdir} ${D}${libdir}
- cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${D}
+ cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
+ mkdir -p ${B}/${PN}
+ cd ${B}/${PN}
+ chmod a+x ${S}/${PN}/configure
+ ${S}/${PN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
+}
+
+do_compile () {
+ target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ cd ${B}/${PN}
+ oe_runmake MULTIBUILDTOP=${B}/$target/${PN}/
+}
+
+do_install () {
+ target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ cd ${B}/${PN}
+ oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${PN}/ install
# Move libgcc_s into /lib
mkdir -p ${D}${base_libdir}
@@ -41,8 +53,11 @@ do_install () {
mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
fi
- chown -R root:root ${D}
- chmod +x ${D}${base_libdir}/libgcc_s.so.*
+ # install the runtime in /usr/lib/ not in /usr/lib/gcc on target
+ # so that cross-gcc can find it in the sysroot
+
+ mv ${D}${libdir}/gcc/* ${D}${libdir}
+ rm -rf ${D}${libdir}/gcc/
}
do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package"